Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 39

Thread: Dell Latitude E6230 Wireless Issues

  1. #11
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    OK, here's what happened (and I'm sorry for taking so long to answer--was off yesterday):

    Booted machine--did not connect--wifi icon just kept "scanning."

    Entered first command--box comes up saying that wireless is disconnected.

    Entered second command--machine connected to "Guest" nearly immediately.

    Unchecked "enable wireless"--icon immediately turned to an "outline" of the wifi icon and machine was disconnected.

    Re-checked "enable wireless" and the machine did NOT connect--icon just keeps "scanning." Although I can see "Guest" in the last of available APs, when I click it a box pops up that says "Guest--You are now disconnected" and the scanning continues.

    Tried a reboot--same story. Icon just keeps "scanning." Just so it's clear--when I reboot if I simply enter:

    Code:
    sudo modprobe wl
    The icon keeps scanning--no connection. I MUST enter the

    Code:
    sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
    FIRST and then enter the

    Code:
    sudo modprobe wl
    command for it to connect to the "Guest" AP. If I only enter one line or another--or enter them out of order--the machine will NOT connect to "Guest." BOTH lines must be entered...and in the same order.

    If at any time I uncheck "Enable Wireless" the machine disconnects from the AP and will NOT connect again unless I re-open a term and re-enter the two modprobe commands.

    Thanks for all your help friends!

    Ron
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  2. #12
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues

    Hi, this line you enter..

    sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma

    is an indication that one or more of those drivers is
    being loaded. Yet they are blacklisted. boot the machine
    and try to connect,but...leave "WL" OUT of the list. I would like
    to determine if other drivers are being loaded or if there is a problem
    with whith the wl driver.
    so on reboot do..
    Code:
    sudo modprobe -r b43 ssb brcmfmac brcmsmac bcma
    

    then.
    Code:
    sudo modprobe wl
    thanks.
    Craving anchovy, herring and squid pizza.....with clam sauce

  3. #13
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hello there,

    OK, I see where you're going with this! I had never had to mess with these drivers so much in the past!

    OK, just rebooted, right now the screen shows the wifi icon (in the upper right) "scanning" and not connecting. It finally timed out and now there is just an outline of the wifi icon with the inside blank.

    Going to a term, I am typing:

    Code:
    sudo modprobe -r b43 ssb brcmfmac brcmsmac bcma
    leaving the "wl" out of the command...and nothing happened of course, and the wifi icon is still an outline.

    Now I am issuing the

    Code:
    sudo modprobe wl
    command.

    Absolutely nothing happened, the wifi icon is still "outlined" and there were no pop-up boxes telling me anything. That kinda surprised me.

    I went back and issued the

    Code:
    sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
    and then the

    Code:
    sudo modprobe wl
    commands, which will usually start up the connection. After a brief minute of "scanning" the machine displayed the "disconnected" box, now it is just "scanning" and will not connect to anything.

    Went ahead and rebooted the machine; the wifi icon is "scanning" as usual--no connection. I then went into a term and issued my original two commands, the

    Code:
    sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
    followed by the

    Code:
    sudo modprobe wl
    command as usual--and of course the machine nearly instantly connected to "Guest."

    I'm not sure what this means but the weirdness is starting to get to me!!

    Thanks,

    Ron

    PS--Just to make sure I'm understanding this--it's the "wl" driver that's making the wifi chipset "work"--correct? By entering the first command I surmise that I am removing those modules (drivers) from memory--then by issuing the second command (the modprobe wl one) I am loading ONLY the "wl" driver, correct? Now I'm guessing that the "blacklist" should prevent the loading of drivers...so, of the package, the "wl" driver should be the only one loading. Am I correct in this description? I care far more about understanding what commands I am issuing than getting the thing to work of course! Thanks.
    Last edited by rondamato; June 20th, 2013 at 04:20 PM. Reason: addition
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  4. #14
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues

    Hi, yes..thats correct the wl driver is what your card
    uses. so lets try the same thing but with just the wl
    and leave the rest out.
    boot..let it fail
    then do..
    Code:
    sudo modprobe -r wl
    sudo modprobe wl
    does it connect?

    also "So at the login screen I click "Raju" and enter password."
    do you have a "list" of possible users..or just Raju...and why would you
    have to choose his name?..if he is the only user besides root..his name
    should be above the password field.
    im trying to get a crystal clear picture of exactly whats going on.
    thanks.
    Last edited by Hadaka; June 20th, 2013 at 04:54 PM.
    Craving anchovy, herring and squid pizza.....with clam sauce

  5. #15
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    OK, trying now.

    Issued the
    Code:
    sudo modprobe -r wl
    command and received the pop-up stating "Disconnected--You are now offline."

    I then entered the
    Code:
    sudo modprobe wl
    command. I got the pop-up "Network Disconnected--You are now offline" followed by the "scanning" icon. The wifi never reconnected. The list of APs is still there, but choosing one just results in the icon "scanning" for awhile, then a message pops up saying "Wireless Network--Disconnected. You are now offline" followed by more scanning. Again, the list of APs is still there, but choosing one will not do anything--it will just continue "scanning."

    I then tried issuing the same two commands that I have been issuing, namely the
    Code:
    sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
    followed by the
    Code:
    sudo modprobe wl
    command, and the machine, again, nearly instantly connects to the "guest" network.

    If all of this is driving you as crazy as it is me please don't let it!! If we cannot knock this one I'd understand and very much appreciate your help...amazing! Thank you.

    Ron

    PS--BTW, it will not let me change it in the CP for these forums for some reason but in case you haven't caught on (/s) I am NOT running Gutsy...I am running 12.04LTS!
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  6. #16
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues

    ok.fun !
    let's try this..
    Code:
    sudo apt-get remove --purge bcmwl-kernel-source
    sudo apt-get install bcmwl-kernel-source
    sudo modprobe wl
    then post this..
    Code:
    dmsg | tail -n 20
    thanks.
    Last edited by Hadaka; June 20th, 2013 at 05:36 PM.
    Craving anchovy, herring and squid pizza.....with clam sauce

  7. #17
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    OK, I purged bcmwl-kernel-source and then reinstalled it. At no time did I lose the wifi connection. It is still sitting up there^ with 4 "bars" of signal strength.

    I then issued the
    Code:
    dmsg|grep wl
    command. It appears as though dmsg is not installed, which is weird. It's telling me that it's in "util-linux" yet when I try to install "util-linux" it tells me that I already have the newest version.

    I then noticed...command was missing an 'e'. Continuing.

    Here are the results:

    [ 2977.497305] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
    [ 2995.859959] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.859971] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.859975] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.859979] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.859982] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.859985] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.859989] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.859993] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.859996] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860000] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860003] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860006] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860009] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860013] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860017] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860020] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860023] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860026] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 2995.860030] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0

    Remember that I have not yet rebooted, and the wifi is connected. At no point did I lose the connection.

    R
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  8. #18
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    OK...just tried rebooting the machine. Here are the results:

    I entered the password to get into the machine and guess what?? OMFG, the icon is there! It's solid! The machine is returning pings!

    Now for the tricky part. I actually shut the machine down, using
    Code:
    sudo shutdown now
    then attempted a cold reboot. Once I logged in the wifi icon was there, but only the "outline." What's very curious is that now, in the list of APs, the "Guest" AP is gone. I tried to connect to a hidden network, and the "Guest" AP was in the dropdown box already. I chose it and the wifi icon started scanning never to connect. I tried connecting to one of the "secure" APs--it asked me for my username and pw as it's supposed to, but never connected. Just keeps "scanning."

    Just for kicks I tried the same two modprobe commands that get me onto "Guest" when I issue them...and the machine connected almost immediately.

    Oh so close and yet so far...

    Ron
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

  9. #19
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Dell Latitude E6230 Wireless Issues

    ok, sorry about the "e"
    the machine needs to not be connected to the wifi
    just boot up..let it not connect..or time out
    then do.
    the same set of commands as before.
    remove then install the driver
    thanks.
    Code:
    dmesg | tail -n 20
    with the "e"
    Craving anchovy, herring and squid pizza.....with clam sauce

  10. #20
    Join Date
    Oct 2007
    Location
    Chicago, IL
    Beans
    51
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dell Latitude E6230 Wireless Issues

    Hello again,

    I disconnected (disabled) wireless networking and tried again. Remember that I had to plug in a piece of hot RJ to be able to dl the driver (as the output from dmesg will show you).

    I removed the drivers (actually purged them) and reinstalled them. I then tried to turn wireless networking back on. Did not get anything besides the "scanning" as usual. Plugged the RJ back in to send this message.

    Here is the result of the dmesg command:


    [ 19.242503] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 19.242504] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 19.242505] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 19.242507] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 19.242508] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 19.242509] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 19.242511] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 19.242512] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 19.242513] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 19.242515] cfg80211: Found new beacon on frequency: 5180 MHz (Ch 36) on phy0
    [ 127.830446] e1000e: eth0 NIC Link is Up 100 Mbps Half Duplex, Flow Control: Rx/Tx
    [ 127.830457] e1000e 0000:00:19.0: eth0: 10/100 speed: disabling TSO
    [ 127.834234] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 250.439675] e1000e: eth0 NIC Link is Down
    [ 255.066730] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 321.753416] audit_printk_skb: 36 callbacks suppressed
    [ 321.753421] type=1400 audit(1371751642.947:24): apparmor="DENIED" operation="capable" parent=1 profile="/usr/sbin/cupsd" pid=893 comm="cupsd" pid=893 comm="cupsd" capability=36 capname="block_suspend"
    [ 337.866929] e1000e: eth0 NIC Link is Up 100 Mbps Half Duplex, Flow Control: Rx/Tx
    [ 337.866940] e1000e 0000:00:19.0: eth0: 10/100 speed: disabling TSO
    [ 337.871248] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

    I'm going to try and reboot but I doubt it will help...

    Right now, the only change is that those two modprobe commands that used to make the wifi work no longer work. Bummer!

    Thanks...I know this has gotten out of hand!

    Ron

    PS--Indeed, rebooting did not help. Wireless still "scanning" and APs are still showing up--just won't let me connect. Running those two modprobe commands will no longer connect me to "guest." I have been doing this a long time and have never ran into such an issue that was SO easy to solve on the surface, yet SO difficult to actually get working when it comes down to it. Hey, at least I'm learning, for what its worth! With these problems you don't really "learn" it until something like this happens...story of my life.
    Last edited by rondamato; June 20th, 2013 at 07:25 PM.
    (The Good) DoctorRon
    Chicago, IL
    <rondamato@gmail.com>
    v7.10 Gutsy Gibbon 32-bit/Gnome

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •