Results 1 to 3 of 3

Thread: No Audio but "test speakers" works

Hybrid View

  1. #1
    Join Date
    May 2007
    Ubuntu 7.10 Gutsy Gibbon

    No Audio but "test speakers" works

    I have a laptop with speakers. I recently tried to watch a flash video on the computer and wasn't getting any sound. Later on I tried to listen to online radio and still wasn't getting any sound. I restarted the computer and it didn't help but when I went into the sound settings and properties I clicked the "test" for each speaker and I'm getting noise through them (the test in gstreamer-properties also works). But ALL other programs will not play any sound to the speakers.

    Same issue as: but that wasn't resolved either

    alsa info dump:

  2. #2
    Join Date
    Apr 2009

    Re: No Audio but "test speakers" works

    Forgive a silly suggestion:

    First, are you running gnome, or kde?

    If gnome, and you have the "indicator applet" on one of your panels, you should see an icon shaped like a conical speaker. Click it, select "properties" and go to the "output" tab. Look at the "connection" item - if it's on "analog output" - you're piping the sound to your speaker connectors on the laptop, to be used by external speakers. If it's on "analog speakers" it should deliver sound to the laptop's on-board speakers.

    "I fear the day technology will surpass our human interaction. The world will have a generation of idiots."
    ― Albert Einstein

  3. #3
    Join Date
    Jun 2007

    Re: No Audio but "test speakers" works

    So it sounds like it's pulseaudio that's borked. Try these commands:
    rm -r ~/.config/pulse
    pulseaudio -k

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts