Results 1 to 4 of 4

Thread: Can't run updates

  1. #1
    Join Date
    Jun 2012

    Can't run updates

    When I try to run updates in ubuntu, I run 'apt-get update', which runs fine, but when I do 'apt-get upgrade' or 'apt-get autoremove' it returns:
    E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
    E: Unable to lock directory /var/cache/apt/archives/
    I think this might be a result of a failed installation of a package a few days ago (It sometimes tells me something about needing to run 'dpkg --configure -a', which only sometimes works) when it froze during installation and I just cancelled it. Any help?

    I'm running Ubuntu 13.04
    Last edited by brickmack; June 12th, 2013 at 08:42 PM.

  2. #2
    Join Date
    Jul 2008
    The Left Coast of the USA

    Re: Can't run updates


    That often happens when you have a GUI package manager open and try to do updates via the terminal, but that is not the only reason it might.

    Is that what is going on? If so, use one method or the other, but don't have both going on at the same time.

    Best wishes!
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  3. #3
    Join Date
    Jun 2012

    Re: Can't run updates

    No, I actually dont even have a GUI on this machine. Ended updeleting /var/cache/apt/archives/lock​ and that fixed it

  4. #4
    Join Date
    Oct 2010
    Lubuntu 13.04 Raring Ringtail

    Re: Can't run updates

    Make sure you type 'sudo' at the beginning of the commands so as to run them as a super user. Limited users don't have full access to updates, upgrades, installations, etc.
    sudo apt-get update && sudo apt-get upgrade


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts