Results 1 to 3 of 3

Thread: Grub2 is playing it REALLY hard

  1. #1
    Join Date
    Jun 2013

    Grub2 is playing it REALLY hard


    hope I choosed right section for this...

    My laptop doesnt have CDROM so i created 1GB FAT partition and burned ubuntu iso like it was USB stick.
    From that time i couldt start my windows or anything from HDD...But while booting PC i pressed F12 and choosed to boof from that 1GB drive...and it worked..i installed ubuntu on 50GB partition on disk. Rebooted. And ? Still no bootloader appeared same thing ...So I booted ubuntu live installed grub on /dev/sda so it should be on MBR and rebooted. I got grub prompt. I can boot my intalled Ubuntu when i write down to prompt following:
    root (hd0,5)
    kernel /boot/vmlinuz-************* root=/dev/sda6
    initrd /boot/initrd-************

    i manually have to write down to grub what he has to do...i booted installed ubuntu, everything worked fine i used update-grub command he found all my operating systems including windows 7 said no error executed 100% correct. Then i rebooted and still grub prompt!
    I reinstalled grub several times, always on MBR pdated it even more times everything alwasy goes well, but i cannot get rid of grub prompt...
    When i wrote to grub this:
    chainloader +1

    screen just flashed and came back to grub prompt, so no windows this way...I got seriously mad and deleted even my windows, used his big partition for my Ubuntu install again selected while isntalling to install grub on /dev/sda but same thing again ...grub prompt...driving me crazy for 3 days...If someone has solution...Another detail...this pc was by factory set to UEFI i changed it in bios to Legacy support even windows was installed using standard bios but new HDDs are compatible and still have MBR so this shouldnt be problem....

    Its late night and im totally destroyded by this evil grub so my vocabulary might be not under 18age...
    Last edited by QIII; June 10th, 2013 at 12:42 AM. Reason: inappropriate language

  2. #2
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Grub2 is playing it REALLY hard

    One issue with new UEFI capable systems is Ubuntu may boot in either UEFI or BIOS mode. You have to boot in same mode as Windows is installed to easily dual boot. And how you boot installer is how it installs.
    UEFI and BIOS write hardware info differently to drive for systems to use, so you cannot dual boot when different systems are not in same mode. You can dual boot if you go into UEFI/BIOS and change to/From UEFI or BIOS to match install.

    Post the link to the BootInfo report that this creates. Is part of Boot-Repair:
    Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
    You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems.
    LighterWeight (Lubuntu based) Boot-RepairCD
    Install in Ubuntu liveCD or USB or Full RepairCD with Boot-Repair (for newer computers)
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Jun 2013

    Re: Grub2 is playing it REALLY hard

    Nice! That Boot-Repair is quite amazing noob-like-me-helper
    Even though i choosed Legacy boot in bios settings that Boot_repair tool said that system is in EFI mode and needs that ~200MB partition...
    After I runned this Boot-Repair some grub started and booted me my Ubuntu. (i still didt created that UEFI partition i guess i wll do it now)
    So I have to reinstall my windows, then install Ubuntu once again and i hope it will we OK...

    I guess my info about booting computer is pretty weak i should spend some nights doing my homework .

    Btw here is link from Boot-Info if someone is interested:


Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts