So I have a fresh install of Ubuntu Gnome 13.04 that worked well for a day or two, long enough to get needed software installed and use it for a bit. Now, suddenly, when I try to boot, I receive the following messages (they flash on the screen for a few brief moments):

[     2.639957] [drm:drm_pci_agp_init] *ERROR* Cannot initialize the agpgart module.
[     2.639961] DRM: Fill_in_dev failed.
and then the machine locks up at a blank black screen.

Here are some things that might be relevant, though I'm just totally guessing, as I have no idea what this error message means:
  1. I have a Radeon 6850 and am using the proprietary fglrx-updates package. This card/driver has given me fits before, but my Windows install seems to be working just fine still, so I don't suspect a hardware issue.
  2. I have to use "quiet splash nomodeset" to get Ubuntu to boot with this card on 12.10 or 13.04.
  3. I can't think of any substantial change that was made before the boot failure, but I did use some PPAs for what I think are trivial things. If someone could let me know a way to check all the PPAs in use on the system from a root prompt, I could provide that.

Here are some things that I have tried so far:
  1. I ran filesystem check, check for broken packages, and autoremove from the recovery menu. No dice.
  2. I tried booting in low graphics mode, but I get the same errors flashing on the screen before a lock up.
  3. From the root prompt, I issues the command
    and I was presented with a working gui, but logged in as root obviously. I didn't do anything as root, just logged back out, but gnome seemed to be working fine.

Here is what I am planning to do next: remove the 6850 and try running the machine on the built in Intel HD 4000, and, if necessary, purge fglrx.

I'd love it if someone could convince me to try something else first, though. I've struggled with fglrx in the past, and I was quite happy that it worked well without fiddling in 13.04.

I found some threads around the net with these errors, but most were quite old, from 2009 or 2010.

Anybody have thoughts?