Results 1 to 4 of 4

Thread: Unable to Install/Update/Etc.

  1. #1
    Join Date
    May 2013
    Beans
    11

    Unable to Install/Update/Etc.

    Hi guys.
    Whenever I try to run apt-get install for a program I'm trying to install (e.g. Synaptic), I get yelled at.

    Code:
     
    $me@me:~$ sudo apt-get install synaptic
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     libjpeg8-dev : Depends: libjpeg8 (= 8d-1) but 8c-2ubuntu7 is to be installed
     synaptic : Depends: libept1.4.12 but it is not going to be installed
                Depends: libvte9 (>= 1:0.24.0) but it is not going to be installed
                Recommends: rarian-compat but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    apt-get -f install yields me with this
    Code:
    $me@me:~$ sudo apt-get install synaptic
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
     libjpeg8-dev : Depends: libjpeg8 (= 8d-1) but 8c-2ubuntu7 is installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies
    Does anyone here have any suggestions/solutions for me? Ubuntu 12.04
    The contents of my sources.list are here:
    http://pastebin.com/AHch11ZB

    Thanks in advance.

  2. #2
    Join Date
    Apr 2011
    Location
    3rd Rock from the Sun
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Unable to Install/Update/Etc.

    Try the following command in the TERMINAL:

    Code:
    sudo dpkg --purge libjpeg8
    sudo apt-get remove --purge libjpeg8
    sudo apt-get autoremove
    sudo apt-get clean
    sudo apt-get -f install
    sudo apt-get update
    sudo apt-get dist-upgrade
    sudo apt-get install synaptic
    If you still get errors, then post the output of sudo apt-get update here.
    "Evolution is Nature's way of issuing upgrades."


  3. #3
    Join Date
    May 2013
    Beans
    11

    Re: Unable to Install/Update/Etc.

    #apt-get update throws no errors, but installing new packages does.
    For instance, trying to install synaptic throws the following code at me.
    Code:
    me@me:~$ sudo apt-get install synapticReading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     libjpeg8-dev : Depends: libjpeg8 (= 8d-1) but 8c-2ubuntu7 is to be installed
     synaptic : Depends: libept1.4.12 but it is not going to be installed
                Depends: libvte9 (>= 1:0.24.0) but it is not going to be installed
                Recommends: rarian-compat but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    Last edited by mjkaufer; June 5th, 2013 at 10:11 PM.

  4. #4
    Join Date
    Apr 2011
    Location
    3rd Rock from the Sun
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Unable to Install/Update/Etc.

    Rerun the commands in post #10 but replace 'libjpeg8' with 'libjpeg8-dev' in the first two commands.
    "Evolution is Nature's way of issuing upgrades."


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •