Results 1 to 8 of 8

Thread: Borked encoding after upgrade

  1. #1
    Join Date
    Jun 2010
    Beans
    167
    Distro
    Ubuntu Gnome

    Exclamation Borked encoding after upgrade

    Hi everybody,

    I managed to do an upgrade from 12.10 to 13.04 x64 with 98% success, as my character encoding has been messed up. Any ideas how to bring this back to the previous, working state? See attached screenshots. On the left is SMPlayer, on the right Skype, both latest version. On 12.10 characters displayed normally.
    Attached Images Attached Images
    Last edited by Inoki; June 23rd, 2013 at 07:15 PM. Reason: Modified distro concerned.

  2. #2
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    871
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Borked encoding after upgrade

    Can you please post the output of this command?
    Code:
    cat /etc/default/locale
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  3. #3
    Join Date
    Jun 2010
    Beans
    167
    Distro
    Ubuntu Gnome

    Re: Borked encoding after upgrade

    Hey, sure,

    Code:
    LANG="sk_SK.UTF-8"LANGUAGE="sk_SK:en_US:en"
    LC_NUMERIC="sk_SK.UTF-8"
    LC_TIME="sk_SK.UTF-8"
    LC_MONETARY="sk_SK.UTF-8"
    LC_PAPER="sk_SK.UTF-8"
    LC_IDENTIFICATION="sk_SK.UTF-8"
    LC_NAME="sk_SK.UTF-8"
    LC_ADDRESS="sk_SK.UTF-8"
    LC_TELEPHONE="sk_SK.UTF-8"
    LC_MEASUREMENT="sk_SK.UTF-8"

  4. #4
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    871
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Borked encoding after upgrade

    Seems correct.
    Can be an error with Slovak language translation see here http://ubuntuforums.org/showthread.php?t=2140746
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  5. #5
    Join Date
    Jun 2010
    Beans
    167
    Distro
    Ubuntu Gnome

    Re: Borked encoding after upgrade

    Quote Originally Posted by dentaku65 View Post
    Seems correct.
    Can be an error with Slovak language translation see here http://ubuntuforums.org/showthread.php?t=2140746
    Thanks, that fixed it.

  6. #6
    Join Date
    Jun 2010
    Beans
    167
    Distro
    Ubuntu Gnome

    Re: Borked encoding after upgrade

    Just to make sure this would be fixed a bug report has been filed: https://bugs.launchpad.net/ubuntu-tr...s/+bug/1191241

  7. #7
    Join Date
    Jun 2010
    Beans
    167
    Distro
    Ubuntu Gnome

    Re: Borked encoding after upgrade

    A workaround has been suggested, in my case however it doesn't work, as I don't have any locale.gen file on my system. Can anybody advise?

  8. #8
    Join Date
    Jun 2010
    Beans
    167
    Distro
    Ubuntu Gnome

    Re: Borked encoding after upgrade

    This workaround fixed it for me.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •