Results 1 to 5 of 5

Thread: amd catalyst 13.4 and ubuntu 12.04.1 weird problem

  1. #1
    Join Date
    May 2011
    Beans
    22

    amd catalyst 13.4 and ubuntu 12.04.1 weird problem

    I have downloaded lates stable catalyst version and genrated the db files according to this https://help.ubuntu.com/community/BinaryDriverHowto/ATI they install successfully, but the module and programs cant be loaded, this is the X log: [ 16.146] (II) LoadModule: "fglrx" [ 16.147] (WW) Warning, couldn't open module fglrx [ 16.147] (II) UnloadModule: "fglrx" [ 16.147] (II) Unloading fglrx [ 16.147] (EE) Failed to load module "fglrx" (module does not exist, 0) amdconfig and amdcccle cant neither be found, but they are there, at /usr/lib/fglrx/bin. Should I discard this and download drivers again via repository?
    Last edited by rogerdv; May 31st, 2013 at 08:52 PM.

  2. #2
    Join Date
    May 2007
    Location
    Virginia, USA
    Beans
    13,234
    Distro
    Ubuntu Mate Development Release

    Re: amd catalyst 13.4 and ubuntu 12.04.1 weird problem

    From what I recently read, Catalyst 13.4 is a Beta version, not a Stable version. Others have had similar problems -- which were corrected when they used the Legacy 13.1 Stable version, instead. You should try that -- link: http://support.amd.com/us/gpudownloa...eon_linux.aspx
    Ubuntu 16.10 Mate, Mint 18 Mate; MS Win 8.1, MS Win10 Pro.
    Will not respond to PM requests for support -- use the forums.

  3. #3
    Join Date
    May 2011
    Beans
    22

    Re: amd catalyst 13.4 and ubuntu 12.04.1 weird problem

    13.6 is beta, 13.4 is stable. I fixed the problem going directly to /usr/lib/... and running aticonfig there, also I uninstalled nvidia driver, restarted and everything started working.

  4. #4
    Join Date
    May 2007
    Location
    Virginia, USA
    Beans
    13,234
    Distro
    Ubuntu Mate Development Release

    Re: amd catalyst 13.4 and ubuntu 12.04.1 weird problem

    Sorry ... because you said 12.04.1, I made the presumption that you were running one of the Legacy HD 2x/3x/4x series cards -- for which Catalyst 13.1 is the stable version.
    Ubuntu 16.10 Mate, Mint 18 Mate; MS Win 8.1, MS Win10 Pro.
    Will not respond to PM requests for support -- use the forums.

  5. #5
    Join Date
    May 2013
    Beans
    9

    Re: amd catalyst 13.4 and ubuntu 12.04.1 weird problem

    Are you using a Radeon 2xxx-4xxx or Radeon 5xxx-7000 series card? If 2xxx-4xxx then you can only use 13.1 legacy - http://www2.ati.com/drivers/legacy/a...x86.x86_64.zip . Use this guide to install - https://help.ubuntu.com/community/BinaryDriverHowto/ATI, but for the
    sudo apt-get install dh-make dh-modaliases execstack
    instead use
    sudo apt-get install dh-make dh-modaliases execstack dkms lib32gcc1 libc6-i386
    or you will get compiling errors.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •