Results 1 to 4 of 4

Thread: Can't enable discrete GPU using vga_switcheroo

  1. #1
    Join Date
    May 2008

    Can't enable discrete GPU using vga_switcheroo

    I recently upgraded (clean install) to Ubuntu 13.04 from 12.10. Everything works much better except for one thing: switchable graphics.

    It was already messy in Ubuntu 12.10. Having a MUXed hybrid Intel Ironlake/AMD 5650m notebook, which is unsupported by Catalyst drivers, my only option was open-source drivers and vga_switcheroo. Even if performance was sub-optimal and I have to restart X every time I wanted to change GPUs, it worked. But now in Ubuntu 13.04 switching to discrete GPU is completely broken.

    The first thing is that switching to discrete GPU the way I used to (in a terminal "echo DDIS > /sys/kernel/debug/vgaswitcheroo/switch" and logout) now makes the X-server crash when I log out. I reported a bug about it:

    Using a nasty workaround posted by Vangel Ajanovski in askubuntu ( I managed to swich to the discrete GPU, but the backlight of the notebook display is off and can't be turned on. It kinda works through HDMI, though. I also reported a bug about this:

    Finally, I discovered that when I am using the Integrated GPU, X-server thinks there is something connected to the DisplayPort. Not only there is noting connected, but this port only works when I am using the discrete GPU, which is properly turned off. Another bug report:

    Have anyone experienced similar problems? Does anyone have any solution? I really don't know where to start debugging this issues.

    Thanks you.

  2. #2
    Join Date
    May 2013

    Re: Can't enable discrete GPU using vga_switcheroo

    I'm having the exact same issues on a intel i915/ATI 5650 combo (muxed) with vga_switcheroo. Trying to switch to DDIS results in freeze. The workaround you linked to didn't make the trick for me. I think it must be something with the new kernels. I noticed you were running 3.8.0-15-generic, I'm on 3.8.0-19-generic (default on 13.04) and just updated to 3.8.0-22 which doesn't work either. I'll attempt to downgrade to older kernels when I get the chance.

    Have you found any solution yet?

  3. #3
    Join Date
    Oct 2006
    Ubuntu Development Release

    Re: Can't enable discrete GPU using vga_switcheroo

    Thread moved to the "Multimedia & Video" forum

  4. #4
    Join Date
    May 2013

    Re: Can't enable discrete GPU using vga_switcheroo

    A little update: the "nasty trick" did it for me as well, it's just that I wasn't connected to HDMI the first time I tried, because it turns out, booting up lightdm with the HDMI connected also results in a freeze. I have no idea where to follow from here.

    For future references, I'm on a HP Envy 14-1110nr.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts