Results 1 to 1 of 1

Thread: Acpi

  1. #1
    Join Date
    May 2013


    Hello forum. A few weeks ago I tried to install Ubuntu server on my desktop machine just to try it out before upgrading to a new server. This installation failed (I don't remember exactly why) and somehow all advanced power options were removed from my BIOS. My fans now run at maximum speed from from the moment I boot.

    After loading Ubuntu 3.2.0-44-generic-pae, I am unable to run "detect-sensors", as in no sensors are found. Other threads have suggested various things including adding a boot option to GRUB2 `GRUB_CMDLINE_LINUX="acpi=off"`. After reboot, I am able to run detect-sensors and control the fanspeed using "fancontrol" service. However, using this boot setting, now Ubuntu is unable to detect duel core.

    The kernel log indicated this with option "acpi=off":
    May 2703:00:26 kernel: [ 0.000000] IOAPIC[0]: apic_id 2, version 32, address 0xfec00000, GSI 0-23
    May 2703:00:26 kernel: [ 0.000000] Processors: 1
    May 2703:00:26 kernel: [ 0.000000] SMP: Allowing 1 CPUs, 0 hotplug CPUs

    and this with option "acpi=on"
    May 2702:49:17 kernel: [ 0.000000] Using ACPI (MADT) for SMP configuration information
    May 2702:49:17 kernel: [ 0.000000] SMP: Allowing 2 CPUs, 0 hotplug CPUs

    With "acpi=on" option, I tried manually loading my sensor drivers into the kernel using `ismod` to no avail.
    # Adapter drivers
    # Chip drivers

    Is there a way to have both acpi=off and duel core on? Originally, all this was handled by the BIOS but somehow now the options don't exist anymore. Flashing the BIOS doesn't seem like a viable option (HP requires XP installation).

    Thanks in advance!
    Last edited by YayaYo; May 27th, 2013 at 06:06 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts