Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: How to Fix Virtual Box Errors After Kernal Updates

  1. #11
    Join Date
    Jul 2006
    South Africa
    Ubuntu 15.04 Vivid Vervet

    Re: How to Fix Virtual Box Errors After Kernal Updates

    I tried
    dpkg -l
    build-essential, dkms, linux-headers-3.8.0-29, linuc-headers-3.8.0-29-generic all seem to be installed.
    I also found the following virtual box items. Perhaps the problem is here somehow.
    ii virtualbox 4.2.10-dfsg-0ubuntu2.1 amd64 x86 virtualization solution - base binaries
    rc virtualbox-4.2 4.2.12-84980~Ubuntu~ra amd64 Oracle VM VirtualBox
    ii virtualbox-dkms 4.2.10-dfsg-0ubuntu2.1 all x86 virtualization solution - kernel module sources for dkms
    ii virtualbox-qt 4.2.10-dfsg-0ubuntu2.1 amd64 x86 virtualization solution - Qt based user interface
    I don't know what the significance of the prefixes ii and rc are but I was wondering if maybe I've somehow double installed or somehow created a clash when I was originally trying to work this all out.

    Next I copied your dpkg -s command with the following result
    $ dpkg -s virtualbox-4.2
    Package: virtualbox-4.2
    Status: deinstall ok config-files
    Priority: optional
    Section: contrib/misc
    Installed-Size: 136062
    Maintainer: Oracle Corporation <>
    Architecture: amd64
    Version: 4.2.12-84980~Ubuntu~raring
    Config-Version: 4.2.12-84980~Ubuntu~raring
    Replaces: virtualbox
    Provides: virtualbox
    Depends: libc6 (>= 2.15), libcurl3 (>= 7.16.2), libdevmapper1.02.1 (>= 2:1.02.20), libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libpng12-0 (>= 1.2.13-4), libpython2.7 (>= 2.7), libqt4-network (>= 4:4.5.3), libqt4-opengl (>= 4:4.7.2), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libsdl1.2debian (>= 1.2.11), libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 4.6), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxinerama1, libxml2 (>= 2.7.4), libxmu6, libxt6, zlib1g (>= 1:1.1.4), psmisc, adduser
    Pre-Depends: debconf (>= 1.1) | debconf-2.0
    Recommends: libasound2, libpulse0, libsdl-ttf2.0-0, dkms, linux-headers, gcc, make, binutils, pdf-viewer, libgl1, python-central
    Conflicts: virtualbox, virtualbox-guest-additions-iso, virtualbox-ose
    /etc/init.d/vboxdrv 91e092513c1ca096e16cd5b74f358b2a
    /etc/init.d/vboxautostart-service 13913287468da586ef47e7c9cae4161d
    /etc/init.d/vboxweb-service 7d3ec328e82e986c612678736730e899
    /etc/init.d/vboxballoonctrl-service fbb712caf488eb8860c4fc20301e7075
    Description: Oracle VM VirtualBox
    VirtualBox is a powerful PC virtualization solution allowing you to run a
    wide range of PC operating systems on your Linux system. This includes
    Windows, Linux, FreeBSD, DOS, OpenBSD and others. VirtualBox comes with a broad
    feature set and excellent performance, making it the premier virtualization
    software solution on the market.
    Python-Version: >= 2.4
    Last edited by howefield; May 13th, 2015 at 08:52 PM.

  2. #12
    Join Date
    Sep 2007
    Oklahoma, USA
    Xubuntu 14.04 Trusty Tahr

    Re: How to Fix Virtual Box Errors After Kernal Updates

    It appears that you've removed the latest build of vbox (4.2.12) and replaced it with an older version, probably from the Ubuntu repositories. At this point, I would use Synaptic to "completely remove" the existing copies of vbox and its accessories, then add the PPA from Oracle's site (which would make their updates feed into the update manager) and finally re-install vbox from the new entry in Synaptic. This ought to pull them all to the same revision level.

    Since vbox normally stores its virtual machines in your home directory, they shouldn't be affected by all this; I've replaced vbox several times over the years with no change to any of my VMs. However to be safe it would be a good idea to copy them to an externam drive if you have enough space available on one (my external backup is more than 200 GB but that's for 14 VMs).

    Those "ii" and "rc" prefixes are explained (rather cryptically) at the top of the "dpkg -l" report; the first letter is desired action, where i means install and r means remove; the second is current status, with i meaning installed and c meaning configuration file only. Thus "ii" means that the package is installed while "rc" means that it was removed but configuration files remain. Doing a "purge" or "completely remove" will get rid of those configuration files.

    You might be able to fix things by simply adding the Oracle PPA to your sources, doing a "Check" in Synaptic to be sure it's added to your local status database, then selecting the new entry for 4.2 that it put into your Synaptic listing and choosing "reinstall" for it. If this does the trick, it's certainly a simpler way to solve the problem.

    Keep us posted!
    Jim Kyle in Oklahoma, USA
    Linux Counter #259718
    Howto mark thread:

  3. #13
    Join Date
    Jul 2006
    South Africa
    Ubuntu 15.04 Vivid Vervet

    [SOLVED] How to Fix Virtual Box Errors After Kernal Updates

    Thanks to both of you for your input. It has got me thinking along the right lines.
    Then, in another thread relating to problematic behaviour of my client OS
    TheFu gave me a link showing me how to specify the headers so that dkms would pick it up correctly.
    I feel quite exited that this problem will now perhaps be behind me.
    Thank you once again.
    I have yet to prove that it works of course but I'm quite confident it will.

    I have since had a kernel update.
    Everything ran smoothly and the client starts up correctly, thus indicating that the kernel modules updated correctly.
    Last edited by howefield; May 13th, 2015 at 08:53 PM.

Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts