Results 1 to 9 of 9

Thread: Cinnamon disable Hot corners

  1. #1
    Join Date
    Oct 2012
    Location
    Eugene, Or
    Beans
    276
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Cinnamon disable Hot corners

    Trying to turn off Hot Corners in Cinnamon on Ubuntu cannot get Cinnamon settings to Run to turn off Hot Corners there, i know there is option on Cinnamon Settings but will not run. Found this but did not Work http://misha.beshkin.lv/disable-hot-...linux-mint-12/. I Know it says for Linux Mint 12 but in the comment this is mentioned "In Mint 13, where they moved from gnome-shell to cinnamon, the configuration file is /usr/share/cinnamon/js/ui/layout.js" so i went with that. Logged out & back in nodda still there so Rebooted Hot Corner still there. Anyone any ideas?


    Dell latitude D600 2Gb Ram Ubuntu 12.04
    Last edited by Redalien0304; May 12th, 2013 at 10:03 PM.
    The Answer Please if at all Possible

  2. #2
    Join Date
    Oct 2012
    Location
    Eugene, Or
    Beans
    276
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Re: Cinnamon disable Hot corners

    So no one knows how to Disable Cinnamon Hot Corners when you cannot access the Cinnamon Settings Panel??
    The Answer Please if at all Possible

  3. #3
    Join Date
    Apr 2013
    Beans
    9

    Re: Cinnamon disable Hot corners

    Right click on the menu and go to settings> all settings> Hot Corners ... you can disable it there.

  4. #4
    Join Date
    Nov 2012
    Beans
    Hidden!

    Re: Cinnamon disable Hot corners

    RIght click on the panel, and there should be a way to access the cinnamon settings from there.

  5. #5
    Join Date
    Oct 2012
    Location
    Eugene, Or
    Beans
    276
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cinnamon disable Hot corners

    Ended up doing a Full Clean Reinstall of Ubuntu 12.04. problem now solved with hot corners. Also Power Icon shows up now on Login screen.
    The Answer Please if at all Possible

  6. #6
    Join Date
    Oct 2005
    Location
    Pennsylvania, USA
    Beans
    86
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Cinnamon disable Hot corners

    Sorry you had to resort to going back to 12.04. I, too, feel that hot corners are a huge annoyance and waste of time. WAY too easy to accidentally hover over one, then you have to click your way out. For me, hot corners are the ultimate in lame.

    That said, I edited the cinnamon layout file using "gksu gedit /usr/share/cinnamon/js/ui/layout.js" and edited the line in the init function:

    From:

    this.hotCornerManager = new HotCorner.HotCornerManager();

    To:

    //this.hotCornerManager = new HotCorner.HotCornerManager();

    thereby commenting it out and effectively disabling the hot corner manager.


    None of the other answers here make any sense, since they apply to a bygone day when there actually was a Hot Corner setting under Cinnamon Settings. I would like to know what happened to it. I would also like to find a way, if any, to make my disabling of the hot corner in the /usr/share file apply just to my account and not the other members of my family who might be annoyed with my disabling of the hot corner annoyance. (I think that would also make my change a bit more permanent for me, since undoubtedly my edit to layout.js will be overwritten once there is another system upgrade.)


    Edit: Oh, and by the way, if I want to manage my workspaces I just use Ctrl-Alt-Up. I cannot think of any good reason to make workspace management a hot corner function. Then again, I cannot think of any function that would be suitable for a hot corner. But that's just me.
    Last edited by flanagan; May 18th, 2013 at 12:13 AM.
    Jim

  7. #7
    Join Date
    Feb 2009
    Beans
    2

    Re: Cinnamon disable Hot corners

    In system settings, there is an icon in the uppper right corner of the window. Click on it, and change to advanced mode. You can modify more things, for example hot corners.

  8. #8
    Join Date
    Jul 2009
    Location
    Austin, Texas, USA
    Beans
    435

    Re: Cinnamon disable Hot corners

    In my installation of Linux Mint 13 with Cinnamon (the version is, I think, 1.2), clicking, in the Menu, on Cinnamon Settings yields a window with an icon labelled "Hot corner".

    Clicking on this icon opens another window, in which you can uncheck the option labelled "Hot corner enabled". With that done, you've liberated yourself from the nuisance of a hot corner. (Of course, if you like being able to switch among two or more desktops, don't uncheck the "Hot corner enabled" option.)

  9. #9
    Join Date
    Oct 2005
    Location
    Pennsylvania, USA
    Beans
    86
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Cinnamon disable Hot corners

    Thanks @pischta. I did not know about the normal vs. advanced mode of system settings. That works great with no need to manually edit layout.js.

    And thanks to rewyllys: I also have Linux Mint 13 on my other old laptop and the Hot Corner icon does indeed work there without unhiding it. I still disable the hot corner and use Ctrl-Alt-Up for switching between workspaces.
    Jim

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •