Results 1 to 2 of 2

Thread: LVM initramfs boot problem: “ALERT! /dev/mapper/vgcrypt-root does not exist."

  1. #1
    Join Date
    Sep 2010
    Beans
    1

    LVM initramfs boot problem: “ALERT! /dev/mapper/vgcrypt-root does not exist."

    I followed the guide linked below to create a clean install of Ubuntu on a LUKS-encrypted partition. The only differences are that I used Ubuntu 12.04 rather than 11.10 and I made less LVs than that guide does (I used 3: swap, root, and home).

    When I boot, I get the message quoted in the title, then get dropped into an initramfs shell. From that shell, I can run `cryptsetup luksOpen /dev/sda2 pvcrypt`, then Ctrl-D to exit the initramfs shell, and everything boots as it should. But I can't figure out how to make it prompt me to open that LUKS archive automatically rather than dropping me into the initramfs shell.

    The guide: http://ubuntuforums.org/showthread.php?t=1867970

    Any suggestions would be greatly appreciated.
    Last edited by klein4; May 22nd, 2013 at 04:26 PM.

  2. #2
    Join Date
    Jul 2005
    Location
    Hughenden, Australia
    Beans
    5,096
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: LVM initramfs boot problem: “ALERT! /dev/mapper/vgcrypt-root does not exist."

    Have you taken a look at your /etc/crypttab file?
    Take a look in the following links, 'Encrypted Filesystem LVM How-to' - Ubuntu Community Docs, see especially this part: final preparation.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •