Results 1 to 9 of 9

Thread: Using radeon graphics card on MacBookPro8,2

Threaded View

  1. #1
    Join Date
    Apr 2013
    Beans
    18

    Using radeon graphics card on MacBookPro8,2

    Hi

    After having a read a bunch of posts I'm still unclear on how to
    1) Use the radeon graphics card
    2) Switch between graphics card.

    My current configuration is ubuntu13.04 with kernel 3.8.0-19-lowlatency and I'm booting in efi mode using efit. I'm currently using the integrated intel graphics card by using the following grub option

    Code:
     
    recordfail
        load_video
        gfxmode $linux_gfx_mode
        insmod gzio
        insmod part_gpt
        insmod btrfs
        set root='hd4,gpt3'
        outb 0x728 1
        outb 0x710 2
        outb 0x740 2
        outb 0x750 0
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd4,gpt3 --hint-efi=hd4,gpt3 --hint-baremetal=ahci4,gpt3  f2e4e4d3-2d8e-4764-a818-de9176405c4b
        else
          search --no-floppy --fs-uuid --set=root f2e4e4d3-2d8e-4764-a818-de9176405c4b
        fi
        echo    'A carregar Linux 3.8.0-19-lowlatency ...'
        linux    /@/boot/vmlinuz-3.8.0-19-lowlatency root=UUID=f2e4e4d3-2d8e-4764-a818-de9176405c4b ro rootflags=subvol=@   video=efifb i915.modeset=1 i915.lvds_channel_mode=2 i915.lvds_use_ssc=0 nosplash
        echo    'A carregar ramdisk inicial ...'
        initrd    /@/boot/initrd.img-3.8.0-19-lowlatency
    This is the only configuration where I've ever managed to boot ubuntu.

    If I try booting with

    Code:
      linux    /@/boot/vmlinuz-3.8.0-19-lowlatency  root=UUID=f2e4e4d3-2d8e-4764-a818-de9176405c4b ro rootflags=subvol=@  nosplash
    The boot procedure just hangs with the message "Cannot initialize Agpart Module".

    If I try booting with

    Code:
    recordfail
        load_video
        gfxmode $linux_gfx_mode
        insmod gzio
        insmod part_gpt
        insmod btrfs
        set root='hd4,gpt3'
        outb 0x728 1
        outb 0x710 2
        outb 0x740 2
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd4,gpt3 --hint-efi=hd4,gpt3 --hint-baremetal=ahci4,gpt3  f2e4e4d3-2d8e-4764-a818-de9176405c4b
        else
          search --no-floppy --fs-uuid --set=root f2e4e4d3-2d8e-4764-a818-de9176405c4b
        fi
        echo    'A carregar Linux 3.8.0-19-lowlatency ...'
        linux    /@/boot/vmlinuz-3.8.0-19-lowlatency root=UUID=f2e4e4d3-2d8e-4764-a818-de9176405c4b ro rootflags=subvol=@ i915.lvds_use_ssc=0 nosplash
        echo    'A carregar ramdisk inicial ...'
        initrd    /@/boot/initrd.img-3.8.0-19-lowlatency
    I get

    Code:
    [    6.849787] [drm] radeon defaulting to kernel modesetting.
    [    6.849790] [drm] radeon kernel modesetting enabled.
    [    6.849846] fb: conflicting fb hw usage radeondrmfb vs EFI VGA - removing generic driver
    [    7.223532] radeon 0000:01:00.0: Invalid ROM contents
    [    7.223631] radeon 0000:01:00.0: Invalid ROM contents
    [    7.223675] [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
    [    7.223723] radeon 0000:01:00.0: Fatal error during GPU init
    [    7.223764] [drm] radeon: finishing device.
    [    7.224999] radeon: probe of 0000:01:00.0 failed with error -22
    I would like to be able to use the radeon graphics card and to be able to switch between cards.

    Any help apreciated.

    Miguel Negrão
    Last edited by miguelnegrao; May 30th, 2013 at 01:55 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •