Results 1 to 5 of 5

Thread: apache 2 problem in restarting

  1. #1
    Join Date
    Jan 2012
    Beans
    55

    apache 2 problem in restarting

    i tried restarting my apache server and it works fine when i browse my local sites i made. but this looks strange. I'm new to ubuntu.
    Code:
     * Restarting web server apache2                                               
     apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    [Wed May 29 18:12:58 2013] [warn] _default_ VirtualHost overlap on port 8080, the first has precedence
     ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    [Wed May 29 18:12:59 2013] [warn] _default_ VirtualHost overlap on port 8080, the first has precedence
                                                                             [ OK ]
    jairoh@jairoh-300E4C-300E5C-300E7C:~$


    anyone can help. tnx

  2. #2
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: apache 2 problem in restarting

    That's not really a problem but a warning. Just insert:
    Code:
    ServerName localhost
    in your apache2.conf file in /etc/apache2 and restart your apache server and the notice will disappear.
    To do it:
    Code:
    gksudo gedit /etc/apache2/httpd.conf
    By default, it would be blank. Simply add the following line:
    Code:
    ServerName localhost
    Save the file, exit gedit and restart the server:
    Code:
    service apache2 restart
    If you have a name inside your /etc/hostname file, you can also use that name instead of localhost.

  3. #3
    Join Date
    Jan 2012
    Beans
    55

    Re: apache 2 problem in restarting

    it tried ur suggestion man but it didn't work.

    when i ran
    Code:
    service apache2 restart
    this appeared
    Code:
    * Restarting web server apache2
    /usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted)
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    [Fri May 31 07:49:37 2013] [warn] _default_ VirtualHost overlap on port 8080, the first has precedence
    /usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted)
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    [Fri May 31 07:49:38 2013] [warn] _default_ VirtualHost overlap on port 8080, the first has precedence
    (13)Permission denied: make_sock: could not bind to address [::]:80
    (13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.
                                                                             [fail]


    but when i ran w/ sudo as prefix


    Code:
    sudo service apache2 restart
    this still appeared
    Code:
    * Restarting web server apache2                                                
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    [Fri May 31 07:49:51 2013] [warn] _default_ VirtualHost overlap on port 8080, the first has precedence
     ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    [Fri May 31 07:49:52 2013] [warn] _default_ VirtualHost overlap on port 8080, the first has precedence
                                                                             [ OK ]
    as you can see. it uses 127.0.1.1 not 127.0.0.1. tsk
    Last edited by jairoh_; May 31st, 2013 at 12:57 AM.

  4. #4
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: apache 2 problem in restarting

    It uses 127.0.1.1 because it is inside your /etc/hosts file:
    Code:
    127.0.0.1 localhost
    127.0.1.1 myhostname

  5. #5
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,292
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: apache 2 problem in restarting

    You need to add

    Code:
    NameVirtualHost *:8080
    somewher ein your config to get rid of the overlap. You can ignore the other warning.
    「明後日の夕方には帰ってるからね。」


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •