Results 1 to 4 of 4

Thread: FN-Keys freeze up System

  1. #1
    Join Date
    Jul 2009
    Beans
    60
    Distro
    Ubuntu 10.04 Lucid Lynx

    FN-Keys freeze up System

    Hi all,

    I'm running XFCE 4.10 on Xubuntu 13.04 on an ancient Gericom notebook. Everything is running fine, but when I use FN keys to adjust the volume or display brightness the system locks up - I can use the mouse, but can't klick on any system menues so I have to use the power button to kill the entire system.
    Is there any way to fix this? Can somebody please help me?

    Thanks for your time!

  2. #2
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    871
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: FN-Keys freeze up System

    Already answered somewhere here.
    For the functional keys seems that Xubuntu (or Xfce 4.10/4.12) is not able to manage them natively; I suggest to solve in this way:
    Code:
    sudo apt-get install gnome-settings-daemon
    Reboot.
    Then under Setting manager -> Session and Startup -> Application Autostart
    Enable Gnome Settings Daemon
    Disable XFCE Volume Daemon
    In Setting manager -> Keyboard -> Application Shortcuts
    Code:
    Remove the shortcuts sets for xfce4-display-settings
    Reboot. Done.
    Last edited by dentaku65; May 20th, 2013 at 06:02 PM.
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

  3. #3
    Join Date
    Jul 2009
    Beans
    60
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: FN-Keys freeze up System

    Quote Originally Posted by dentaku65 View Post
    Already answered somewhere here.
    For the functional keys seems that Xubuntu (or Xfce 4.10/4.12) is not able to manage them natively; I suggest to solve in this way:
    Code:
    sudo apt-get install gnome-settings-daemon
    Reboot.
    Then under Setting manager -> Session and Startup -> Application Autostart

    In Setting manager -> Keyboard -> Application Shortcuts
    Code:
    Remove the shortcuts sets for xfce4-display-settings
    Reboot. Done.
    Caro dentaku65,

    mille grazie per la riposta. It solved the problem partially, as of I can now manipulate the display brightness without lockup, but the volume keys still seem to freeze xfce. I've followed all your steps, and would kindly ask for any other idea.

    Thanks,

    Elvis

  4. #4
    Join Date
    Oct 2005
    Location
    Milano, Italy
    Beans
    871
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: FN-Keys freeze up System

    Hi,
    please check in Setting manager -> Keyboard -> Application Shortcuts if there is any set for:
    VolumeUp
    VolumeDown
    Mute
    If so, remove these shortucuts
    ------------------------------------------------
    yep ”short and long URL„
    http://yep.it/
    ------------------------------------------------

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •