Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Can't get wifi connection over 150Mbps

  1. #11
    Join Date
    May 2013
    Beans
    5

    Re: Can't get wifi connection over 150Mbps

    Sorry to ruin the party guys, but I've been trying the kernel versions thing with no good results. Seems to be a solution for some cases only. I updated to Ubuntu 13.04 with 72Mbps top connections. Upgraded manually to kernel 3.9.2 also with no luck (had to go back to 3.8 because ATI legacy drivers don't work in 3.9). In this last case, connections were back to 150Mbps. I guess its something just to try ut.

    Thank you anyway for all your help!

  2. #12
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't get wifi connection over 150Mbps

    Quote Originally Posted by diegosolo View Post
    Sorry to ruin the party guys, but I've been trying the kernel versions thing with no good results.
    Hmm.. that only proves to me that the driver alone is not the deciding factor for the speed, which is somewhat obvious. But since changing kernel alone was enough for toothandnail (as far as he told us) to improve the speeds, it definitely is a helping factor, if not the only one.

    Did you try changing the power management on wireless from "on" to "off" ? Did you check whether it sticked or not (iwconfig)?
    Please show us the current status of-
    Code:
    iwconfig
    ifconfig
    grep -iR [a-z0-9] /sys/module/iwlwifi/parameters/
    sudo iwlist wlan0 scan
    Also, it is recommended to use pure WPA2-PSK mode encryption in the router, and especially not WPA/WPA2 mixed mode.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #13
    Join Date
    May 2013
    Beans
    5

    Re: Can't get wifi connection over 150Mbps

    Turning power management off didn't work. Here is the info you requested:

    iwconfig
    Code:
    wlan0     IEEE 802.11abgn  ESSID:"Diegosolo5"  
              Mode:Managed  Frequency:5.18 GHz  Access Point: A0:F3:C1:8F:93:6C   
              Bit Rate=6 Mb/s   Tx-Power=14 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=60/70  Signal level=-50 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:2  Invalid misc:87   Missed beacon:0
    
    
    lo        no wireless extensions.
    
    
    eth0      no wireless extensions.
    ifconfig
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:26:9e:10:af:42  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:1004 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1004 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:87760 (87.7 KB)  TX bytes:87760 (87.7 KB)
    
    
    wlan0     Link encap:Ethernet  HWaddr 00:1e:65:82:f1:3a  
              inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::21e:65ff:fe82:f13a/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:13989 errors:0 dropped:0 overruns:0 frame:0
              TX packets:7741 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:14007447 (14.0 MB)  TX bytes:940118 (940.1 KB)
    grep -iR [a-z0-9] /sys/module/iwlwifi/parameters/
    Code:
    /sys/module/iwlwifi/parameters/5ghz_disable:N
    /sys/module/iwlwifi/parameters/swcrypto:0
    /sys/module/iwlwifi/parameters/power_save:N
    /sys/module/iwlwifi/parameters/auto_agg:Y
    /sys/module/iwlwifi/parameters/led_mode:0
    /sys/module/iwlwifi/parameters/amsdu_size_8K:1
    /sys/module/iwlwifi/parameters/bt_ch_inhibition:Y
    /sys/module/iwlwifi/parameters/fw_restart:1
    /sys/module/iwlwifi/parameters/bt_coex_active:Y
    /sys/module/iwlwifi/parameters/11n_disable:0
    /sys/module/iwlwifi/parameters/antenna_coupling:0
    /sys/module/iwlwifi/parameters/plcp_check:Y
    /sys/module/iwlwifi/parameters/wd_disable:1
    /sys/module/iwlwifi/parameters/power_level:0
    sudo iwlist wlan0 scan
    Code:
    wlan0     Scan completed :
              Cell 01 - Address: A0:F3:C1:8F:93:6C
                        Channel:36
                        Frequency:5.18 GHz (Channel 36)
                        Quality=62/70  Signal level=-48 dBm  
                        Encryption key:on
                        ESSID:"Diegosolo5"
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                                  36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=0000003d5fbe435d
                        Extra: Last beacon: 274028ms ago
                        IE: Unknown: 000A446965676F736F6C6F35
                        IE: Unknown: 01088C129824B048606C
                        IE: Unknown: 030124
                        IE: Unknown: 074C4152202401112801112C01113001113401183801183C01184001186401186801186C01187001187401187801187C01188001188401188801188C011895011E99011E9D011EA1011EA5011E00
                        IE: Unknown: 200100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 2D1AEF011BFFFFFF00000000000000000000000000000406E6E70D00
                        IE: Unknown: 331AEF011BFFFFFF00000000000000000000000000000406E6E70D00
                        IE: Unknown: 3D16240D0000000000000000000000000000000000000000
                        IE: Unknown: 3416240D0000000000000000000000000000000000000000
                        IE: Unknown: DD180050F2020101850003A4000027A4000042435E0062322F00
                        IE: Unknown: DD0900037F01010000FF7F
              Cell 02 - Address: A0:F3:C1:8F:93:6C
                        Channel:36
                        Frequency:5.18 GHz (Channel 36)
                        Quality=61/70  Signal level=-49 dBm  
                        Encryption key:on
                        ESSID:""
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                                  36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=0000003d703c203b
                        Extra: Last beacon: 100ms ago
                        IE: Unknown: 0000
                        IE: Unknown: 01088C129824B048606C
                        IE: Unknown: 030124
                        IE: Unknown: 050400010000
                        IE: Unknown: 074C4152202401112801112C01113001113401183801183C01184001186401186801186C01187001187401187801187C01188001188401188801188C011895011E99011E9D011EA1011EA5011E00
                        IE: Unknown: 200100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 2D1AEF011BFFFFFF00000000000000000000000000000406E6E70D00
                        IE: Unknown: 3D16240D0000000000000000000000000000000000000000
                        IE: Unknown: DD180050F2020101850003A4000027A4000042435E0062322F00
                        IE: Unknown: DD0900037F01010000FF7F
              Cell 03 - Address: 00:23:CD:1E:C9:F0
                        Channel:4
                        Frequency:2.427 GHz (Channel 4)
                        Quality=45/70  Signal level=-65 dBm  
                        Encryption key:off
                        ESSID:"QUE MALA SEGURIDAD"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s
                        Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=0000003debf392ea
                        Extra: Last beacon: 0ms ago
                        IE: Unknown: 0012515545204D414C4120534547555249444144
                        IE: Unknown: 010882848B960C121824
                        IE: Unknown: 030104
                        IE: Unknown: 2A0100
                        IE: Unknown: 32043048606C
                        IE: Unknown: DD180050F2020101860003A4000027A4000042435E0062322F00
                        IE: Unknown: DD1E00904C334E111BFF00000000000000000000000000000000000000000000
                        IE: Unknown: 2D1A4E111BFF00000000000000000000000000000000000000000000
                        IE: Unknown: DD1A00904C3404051B00000000000000000000000000000000000000
                        IE: Unknown: 3D1604051B00000000000000000000000000000000000000
                        IE: Unknown: DD0900037F01010000FF7F
                        IE: Unknown: DD0A00037F04010000004000
                        IE: Unknown: DD880050F204104A0001101044000101103B00010310470010000000000000100000000023CD1EC9F01021000754502D4C494E4B10230009544C2D57523734304E10240003312E3010420003312E301054000800060050F204000110110020576972656C657373204C697465204E20526F7574657220544C2D57523734304E100800020086103C000101
              Cell 04 - Address: 00:13:33:9A:87:4A
                        Channel:11
                        Frequency:2.462 GHz (Channel 11)
                        Quality=25/70  Signal level=-85 dBm  
                        Encryption key:on
                        ESSID:"TODOPC_WIFI"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s
                        Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=0000007d39fcafa7
                        Extra: Last beacon: 0ms ago
                        IE: Unknown: 000B544F444F50435F57494649
                        IE: Unknown: 010882848B960C121824
                        IE: Unknown: 03010B
                        IE: Unknown: 2A0100
                        IE: Unknown: 32043048606C
                        IE: Unknown: 2D1A6E181EFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D160B070000000000000000000000000000000000000000
                        IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                        IE: Unknown: DD9E0050F204104A0001101044000102103B00010310470010630412531019200612280013339A87481021001B5265616C74656B2053656D69636F6E647563746F7220436F72702E1023000752544C387878781024000D45562D323030392D30322D30361042000F3132333435363738393031323334371054000800060050F2040001101100135265616C74656B20576972656C657373204150100800020086
                        IE: Unknown: DD050050F20500
                        IE: Unknown: DD1E00904C336E181EFFFF000000000000000000000000000000000000000000
                        IE: Unknown: DD1A00904C340B070000000000000000000000000000000000000000
                        IE: Unknown: DD0600E04C020120
    Thank you!

  4. #14
    Join Date
    May 2013
    Beans
    5

    Re: Can't get wifi connection over 150Mbps

    Oh! I forgot. I'm using WPA2-PSK security with AES encription.

  5. #15
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't get wifi connection over 150Mbps

    Quote Originally Posted by diegosolo View Post
    iwconfig
    Code:
    wlan0     IEEE 802.11abgn  ESSID:"Diegosolo5"  
              Mode:Managed  Frequency:5.18 GHz  Access Point: A0:F3:C1:8F:93:6C   
              Bit Rate=6 Mb/s   Tx-Power=14 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=60/70  Signal level=-50 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:2  Invalid misc:87   Missed beacon:0
    6 Mb/s ?? Wasn't it supposed to be 150 Mb/s ?
    How about setting it to be fixed at 150 Mb/s rather than auto (which it currently seems to be set at) -
    Code:
    sudo iwconfig wlan0 rate 150M
    ..or a slightly lower one that is supported.

    Speaking of 'supported' speeds, your iwlist scan output doesn't show anything above 54 Mb/s, but to be honest, I am an absolute noob at understanding its output, and not sure how else to verify the supported speeds if higher ones exist.

    (I'd be very grateful if someone can explain that to me regarding N-channel speeds.)

    grep -iR [a-z0-9] /sys/module/iwlwifi/parameters/
    Code:
    /sys/module/iwlwifi/parameters/5ghz_disable:N
    /sys/module/iwlwifi/parameters/swcrypto:0
    ....
    That ^^ is a new parameter in iwlwifi driver, doesn't exist in the version on my system (12.04.2). But it seems that it is meant to disable the 5ghz channel which is supposed to provide higher speed. I'm not sure if the 2.4ghz channels can provide the 300mbps speed, so can't say if it may be worth messing with this parameter and go about doing changes in the router itself.

    A quote from this post by bellaseem may be relevant here (not sure where he quoted it from) :
    "The fact that you have strong signal but not at least the 65mbps data rate suggests that your client is limiting itself to G mode operation for some reason. The most common reasons are:

    1. The router is not set to do N on its 2.4GHz radio.
    2. Your router or your client is configured to use WEP or TKIP (WPA1) encryption, not AES-CCMP (WPA2). WEP and TKIP, as implemented by most Wi-Fi gear, is not fast enough to keep up with N rates, so the 802.11n spec disallows using those modes with 802.11n connections. To get N rates, you have to use AES-CCMP or no encryption.
    3. Your AP (or I suppose your client) does not have QoS (802.11e, WMM) enabled. The 802.11n spec requires QoS."
    So make sure the last point is true in your case.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •