Results 1 to 9 of 9

Thread: Welcome to Nginx! Will not get off my local

Threaded View

  1. #1
    Join Date
    May 2013

    Welcome to Nginx! Will not get off my local

    Hello to everyone that will read this,

    Lets start by saying I am completely new to Linux but am pretty well off on my computer skills. I was trying to set up a Drupal site for my employer and saw a link talking about running Drupal 8. It recommended that I used nginx so I installed it. Once that was done and I took care of installing php5,mysqlAdmin, and apache2 i had the issue of whichever pages I created even when there is only an index.php file in the var/www/ file that seems to still pop up with nginx. With my frustration I did uninstall nginx which i have checked to see if those files are gone and it does say it is. I checked by doing a cd /var/www/ and then ls which shows a index.php and myPhpAdmin.

    I am still having issues with even starting apache as well. I get a 87: ulimit: error setting limit (operation not permitted) (13) Permission denied: for 80 and I know i seemed to have this problem about some kind of password phrase key that I thought I fixed before but is apparently not working now.

    Is there anyway that nginx might of made some files invisible?
    By chance is Apache2 Server have some setup that was messed with to have it auto direct files to this nginx site?
    Is there a more permenant solution to getting apache2 to start up with no issues? (this problem I will probably figure out myself as I tried uninstalling apache2 to see if that would fix it so I think i have to reset that password stuff.)

    Any way, any help is greatly appreciated. I am not to savvy with Linux so I am unsure of what to post for you guys to make things easier. Please let me know what I could post for you to help though.
    I do know that I have Ubuntu 13.04 and so far have very standard settings.

    *Added 5/20/2013*
    I have worked passed the password issue but i get a 98 address already in use. I use the sudo netstat -ltnp | grep ':80' and it shows me that nginx is using the sockets. If I kill it, it takes the next socket and then is tagged as nginx: worker. Not sure why this exists since i uninstalled nginx.
    Last edited by CharlesA; May 29th, 2013 at 04:34 PM. Reason: mark as solved

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts