Page 7 of 16 FirstFirst ... 56789 ... LastLast
Results 61 to 70 of 159

Thread: Wirless works, wired does not

  1. #61
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wirless works, wired does not

    Quote Originally Posted by GUZZLR View Post
    Oh...you're right, I think I see a difference between the two on inet addr?
    Right. I'll be busy for a couple of hours, meanwhile here a quick one to try-

    Turn off your wireless interface using hardware switch (a physical switch or a key combination, whatever you have on your Dell to toggle it on/off). Wait about 10-20 seconds, THEN connect the cable to the router. Make sure wired connection is enabled in Network manager and is set to pick up IP automatically (DHCP).

    Any difference?
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  2. #62
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Wirless works, wired does not

    Dell= Fn/F2 wireless toggle on/off
    Craving anchovy, herring and squid pizza.....with clam sauce

  3. #63
    Join Date
    Apr 2013
    Beans
    262

    Re: Wirless works, wired does not

    Switched it off phically, plugged the cable in and did not change anything.

  4. #64
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Wirless works, wired does not

    fun stuff... did you run.
    Code:
    sudo apt-get purge qemu-kvm
    and have you done updates/upgrades?
    while connected to the internet..
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    and have you tried setting up an ssid with
    no encryption..open/none?
    Craving anchovy, herring and squid pizza.....with clam sauce

  5. #65
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wirless works, wired does not

    Funny indeed! And interesting, and frustrating, and mysterious.... what a recipe!

    Let's crosscheck a few things. Please post the outputs of the following -
    Code:
    cat /etc/network/interfaces
    sudo grep -iRl ethernet /etc/NetworkManager/system-connections/ | while read line; do echo -e "\n\n$line" && sudo cat "$line"; done
    The second command (sudo grep.....) is a tiny script that has to be typed (or copy-pasted) as a single line in the terminal.

    CAUTION ! : Before posting, make sure the output of the second command does not contain any sensitive data like saved id/passwords for wireless, DSL etc. Although I've made sure such files are not covered, but just to be sure

    After running on the Dell lappy, also run the same commands on the Chromebook (whether it is connected to the router or not, is not important for these commands). Post back both sets of outputs for comparison.

    Hopefully, these may help pin-pointing the source of the problem, or at least simplify the puzzle.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  6. #66
    Join Date
    Apr 2013
    Beans
    262

    Re: Wirless works, wired does not

    Code:
    charles@Raspberry:~$ sudo apt-get purge qemu-kvm
    [sudo] password for charles: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package 'qemu-kvm' is not installed, so not removed
    The following packages were automatically installed and are no longer required:
      dkms kde-l10n-engb libkprintutils4 libokularcore2abi1 libqimageblitz4
      linux-headers-generic linux-image-extra-3.8.0-19-generic linux-image-generic
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    charles@Raspberry:~$ sudo apt-get update
    Hit http://mirror.anl.gov raring Release.gpg
    Hit http://mirror.anl.gov raring-updates Release.gpg
    Hit http://mirror.anl.gov raring-backports Release.gpg
    Hit http://mirror.anl.gov raring-security Release.gpg
    Hit http://mirror.anl.gov raring Release
    Hit http://mirror.anl.gov raring-updates Release
    Hit http://mirror.anl.gov raring-backports Release
    Hit http://mirror.anl.gov raring-security Release
    Hit http://mirror.anl.gov raring/main Sources   
    Hit http://mirror.anl.gov raring/restricted Sources
    Hit http://mirror.anl.gov raring/universe Sources
    Hit http://mirror.anl.gov raring/multiverse Sources
    Hit http://mirror.anl.gov raring/main i386 Packages
    Hit http://mirror.anl.gov raring/restricted i386 Packages
    Hit http://mirror.anl.gov raring/universe i386 Packages
    Hit http://mirror.anl.gov raring/multiverse i386 Packages
    Hit http://mirror.anl.gov raring/main Translation-en
    Hit http://mirror.anl.gov raring/multiverse Translation-en
    Hit http://mirror.anl.gov raring/restricted Translation-en
    Hit http://mirror.anl.gov raring/universe Translation-en
    Hit http://mirror.anl.gov raring-updates/main Sources
    Hit http://mirror.anl.gov raring-updates/restricted Sources
    Hit http://mirror.anl.gov raring-updates/universe Sources
    Hit http://mirror.anl.gov raring-updates/multiverse Sources
    Hit http://mirror.anl.gov raring-updates/main i386 Packages
    Hit http://mirror.anl.gov raring-updates/restricted i386 Packages
    Hit http://mirror.anl.gov raring-updates/universe i386 Packages
    Hit http://mirror.anl.gov raring-updates/multiverse i386 Packages
    Hit http://mirror.anl.gov raring-updates/main Translation-en
    Hit http://mirror.anl.gov raring-updates/multiverse Translation-en
    Hit http://mirror.anl.gov raring-updates/restricted Translation-en
    Hit http://mirror.anl.gov raring-updates/universe Translation-en
    Hit http://mirror.anl.gov raring-backports/main Sources
    Hit http://mirror.anl.gov raring-backports/restricted Sources
    Hit http://mirror.anl.gov raring-backports/universe Sources
    Hit http://mirror.anl.gov raring-backports/multiverse Sources
    Hit http://mirror.anl.gov raring-backports/main i386 Packages
    Hit http://mirror.anl.gov raring-backports/restricted i386 Packages
    Hit http://mirror.anl.gov raring-backports/universe i386 Packages
    Hit http://mirror.anl.gov raring-backports/multiverse i386 Packages
    Hit http://mirror.anl.gov raring-backports/main Translation-en
    Hit http://mirror.anl.gov raring-backports/multiverse Translation-en
    Hit http://mirror.anl.gov raring-backports/restricted Translation-en
    Hit http://mirror.anl.gov raring-backports/universe Translation-en
    Hit http://mirror.anl.gov raring-security/main Sources
    Hit http://mirror.anl.gov raring-security/restricted Sources
    Hit http://mirror.anl.gov raring-security/universe Sources
    Hit http://mirror.anl.gov raring-security/multiverse Sources
    Hit http://mirror.anl.gov raring-security/main i386 Packages
    Hit http://mirror.anl.gov raring-security/restricted i386 Packages
    Hit http://mirror.anl.gov raring-security/universe i386 Packages
    Hit http://mirror.anl.gov raring-security/multiverse i386 Packages
    Hit http://mirror.anl.gov raring-security/main Translation-en
    Hit http://mirror.anl.gov raring-security/multiverse Translation-en
    Hit http://mirror.anl.gov raring-security/restricted Translation-en
    Hit http://mirror.anl.gov raring-security/universe Translation-en
    Ign http://mirror.anl.gov raring/main Translation-en_US
    Ign http://mirror.anl.gov raring/multiverse Translation-en_US
    Ign http://mirror.anl.gov raring/restricted Translation-en_US
    Ign http://mirror.anl.gov raring/universe Translation-en_US
    Ign http://mirror.anl.gov raring-updates/main Translation-en_US
    Ign http://mirror.anl.gov raring-updates/multiverse Translation-en_US
    Ign http://mirror.anl.gov raring-updates/restricted Translation-en_US
    Ign http://mirror.anl.gov raring-updates/universe Translation-en_US
    Ign http://mirror.anl.gov raring-backports/main Translation-en_US
    Ign http://mirror.anl.gov raring-backports/multiverse Translation-en_US
    Ign http://mirror.anl.gov raring-backports/restricted Translation-en_US
    Ign http://mirror.anl.gov raring-backports/universe Translation-en_US
    Ign http://mirror.anl.gov raring-security/main Translation-en_US
    Ign http://mirror.anl.gov raring-security/multiverse Translation-en_US
    Ign http://mirror.anl.gov raring-security/restricted Translation-en_US
    Ign http://mirror.anl.gov raring-security/universe Translation-en_US
    Reading package lists... Done
    charles@Raspberry:~$ sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    charles@Raspberry:~$
    AS far as setting up router with a new SSID, not sure how to do that, I have reset both routers and taken away any passwords and firewalls. Also, the D-Link router offers a Guest area which I have tried, but that didnt work either

  7. #67
    Join Date
    Apr 2013
    Beans
    262

    Re: Wirless works, wired does not

    I don't know if this will help. Here are the two lines of code I originally used to get my wireless running, when I originally installed Ubuntu. These two lines I also used originally to get 12.10 to work, when I went from 12.10 to 13.04, I had to use them again. However, this was just to get wireless working, my wired connection has never worked on his machine running either Ubuntu 12.10 or 13.04. The wired connection did work with Windows XP, just not Ubuntu.
    Now here's the odd part about this, if you look at the attached screen shot, you'sll notice that I have the Broadcom drivers unchecked in "Software & Updates > Additional Drivers" If I use the drivers, I loose my wireless...so I have to go back and check the "do not use the device". So this is odd to me because wireless does not work unless I use the two lines of code to get the drivers, but then I have to not use them to get wireless to work...seems backwards to me.
    Code:
       sudo apt-get purge b43-fwcutter firmware-b43-installer firmware-b43-lpphy-installer firmware-b43legacy-installer bcmwl*
     sudo apt-get install b43-fwcutter firmware-b43-installer bcmwl*
    Screenshot from 2013-05-26 10:35:10.png

  8. #68
    Join Date
    Apr 2013
    Beans
    262

    Re: Wirless works, wired does not


    Here's what I get:


    Code:
       Input using Dell on wireless:
     charles@Raspberry:~$ cat /etc/network/interfaces  
     # interfaces(5) file used by ifup(8) and ifdown(8)  
     auto lo  
     iface lo inet loopback  
     charles@Raspberry:~$ sudo grep -iRl ethernet /etc/NetworkManager/system-connections/ | while read line; do echo -e "\n\n$line" && sudo cat "$line"; done  
     [sudo] password for charles:  
     
    
     
    
     /etc/NetworkManager/system-connections/Auto Ethernet  
     [802-3-ethernet]  
     duplex=full  
     mac-address=00:1C:23:38:FC:08  
     
    
     [connection]  
     id=Auto Ethernet  
     uuid=56b84ee9-a71c-45d8-b94a-e5197612fa09  
     type=802-3-ethernet  
     timestamp=1369526519  
     
    
     [ipv6]  
     method=ignore  
     
    
     [ipv4]  
     method=auto  
     charles@Raspberry:~$  
     
    
     Input using Chromebook on wireless:
     user@ChrUbuntu:~$ cat /etc/network/interfaces 
     auto lo 
     iface lo inet loopback 
     
     user@ChrUbuntu:~$ sudo grep -iRl ethernet /etc/NetworkManager/system-connections/ | while read line; do echo -e "\n\n$line" && sudo cat "$line"; done 
     [sudo] password for user:  
     user@ChrUbuntu:~$  

  9. #69
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Wirless works, wired does not

    The wireless driver you have loaded is basically correct..b43
    The bcm 4311 card uses the ssb module and b43 driver.
    the Sta Broadcom-kernel-source driver "wl" ,blackists the ssb
    module by default and design. Why the sta driver always shows
    up in proprietary drivers is beyond me, it is a constant source of
    trouble. what you have check is correct. The 4311 card really runs
    best on the linux-firmware-nonfree dirver. But, since you have no
    wired connection,you cannot load it at this time.
    Craving anchovy, herring and squid pizza.....with clam sauce

  10. #70
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Wirless works, wired does not

    Hi, I noticed in the output from the last command
    varunendra had you try there was no IPv4 listed.
    please click your wireless icon..
    click Edit connections..
    click Wired
    click your ssid name
    click Edit
    click IPv4 settings
    and post a screen shot of that..
    thanks.
    Craving anchovy, herring and squid pizza.....with clam sauce

Page 7 of 16 FirstFirst ... 56789 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •