Results 1 to 2 of 2

Thread: 2 Monitor issue when playing brood war

  1. #1
    Join Date
    Sep 2011
    Beans
    1

    2 Monitor issue when playing brood war

    Hello,

    I'm having some issues with the monitors when I'm playing Starcraft Brood War. I have a 2 Monitor setup : BenQ GW2450H (primary) and a Philips 226V4.

    When I start the game with wine it starts and works flawlessly on the Philips monitor and the BenQ just enters stand-by. After I exit the game it remains on standby until I do logout or a reboot and that's very annoying as I don't really want to terminate my session to be capable to use the second monitor.

    The monitors are connected through DVI , the graphics card is a Gigabyte GV-N220OC-1GI and the driver is : 304.88. I've attached my xorg.conf and also the output from xrandr.

    Code:
    cat /etc/X11/xorg.conf
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 295.33  (buildd@allspice)  Fri Mar 30 13:37:33 UTC 2012
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    
    Section "Files"
    EndSection
    
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "BenQ GW2450H"
        HorizSync       30.0 - 83.0
        VertRefresh     50.0 - 76.0
        Option         "DPMS"
    EndSection
    
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GT 220"
    EndSection
    
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "DFP: 1920x1080 +0+0, CRT: nvidia-auto-select +1920+0"
        Option       "metamodes" "DFP: 640x480 +0+0, CRT: nvidia-auto-select +1920+0"
        SubSection     "Display"
            Depth       24
        Modes        "1024x768"
        EndSubSection
    EndSection
    and

    Code:
    xrandr
    Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 8192 x 8192
    DVI-I-0 disconnected (normal left inverted right x axis y axis)
    VGA-0 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 477mm x 268mm
       1920x1080      60.0*+
       1680x1050      60.0  
       1440x900       75.0     59.9  
       1280x1024      75.0     60.0  
       1280x720       60.0  
       1024x768       75.0     60.0  
       800x600        75.0     60.3  
       640x480        75.0     72.8     59.9  
    DVI-I-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 298mm
       1920x1080      60.0*+
       1680x1050      60.0  
       1600x900       60.0  
       1280x1024      75.0     60.0  
       1280x960       60.0  
       1280x800       59.8  
       1280x720       60.0  
       1024x768       75.0     60.0  
       1024x576       60.0  
       800x600        75.0     60.3  
       640x480        75.0     59.9  
    HDMI-0 disconnected (normal left inverted right x axis y axis)
    I hope you guys have some ideas on how to fix this.

    Thanks

  2. #2
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,508
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 2 Monitor issue when playing brood war

    You could probably use xrandr to ping the monitors awake by setting the resolution of both of them to what they should be. You might even be able to script it as part of the process of launching Starcraft.

    Or you could just run Starcraft in a window.
    None but ourselves can free our minds

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •