Results 1 to 6 of 6

Thread: Problem with read-only backup

Threaded View

  1. #1
    Join Date
    May 2013

    Problem with read-only backup

    I am trying to put together a bash script to backup a few NFS shares. I am still working through this and have been learning bash as I go. The shares are mounted as read-only. The script uses rsync to copy files from the NFS device to a Drobo mounted over iSCSI. I ran a test backup and it didn't really work, but now I can't get rid of the backup files because they are read-only. I have tried changing the permissions, but when i try:
     rm -rf <directory>
    , I get a long print out of each file like:
    cannot remove <file> read-only filesystem
    . Right now I just want to delete these backups, later I will worry about reworking my script. Does anyone have any advice?
    Last edited by dan08; May 14th, 2013 at 08:14 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts