I don't know if this is really an Ubuntu problem but thought I'd post here as a first go at solving this....

My mainboard is an Intel DX48BT2. I have it configured to treat SATA drives as AHCI and I have UEFI boot enabled in the BIOS.

My SATA drives are:
SATA0 : Seagate ST3000DM001 (3TB)
SATA1 : Sony DVD-RW
SATA2 : Pioneer Blu-Ray

I am booting Ubuntu 13.04 x86_64 from a USB stick. I can boot the USB stick just fine. Initially I went into the installer and I specified my partition layout like this:

1MB : GPT Reserved Area
128MB (ext2) : /boot
~2.99TB (ext4) : /
8198MB : swap

I am also telling the installer to install the bootloader into the MBR (using the option in the installer GUI)

When I try to boot, the computer fails to boot claiming "no bootable device found". I re-booted into my USB stick and (thinking something was wrong with my partitioning), I used gparted to re-initialize the drive as a GPT drive with no paritions defined. I then went through the Ubuntu installer and let it select its own default scheme. This yielded the same problem - "no bootable device found"

I pulled out my 3TB drive and put in a 1.5TB drive and it works just fine. I pulled that out and put in an older 3TB drive that I've used before and it worked just fine.

I re-installed my new 3TB drive and checked the partitions and I see them all there. I can mount and browse them and I see the files I expect. I rebooted into my USB stick and installed "boot-repair" and ran it. I did the default repair and it says that it was successful but upon reboot, I get the same error -- "no bootable device found."

I used gparted again to clean the drive, but this time I configured it as a standard MBR-type disk (I was okay with losing the extra space for the sake of this test) and then installed Ubuntu using the default partition scheme. It still won't boot.

It seems to me (I may be wrong) that the partitions are okay but it's the MBR that is messed up in that the BIOS cannot find where to boot from. Is this correct?

I did some Googling and came across these references:
http://forums.gentoo.org/viewtopic-t-716015.html
http://blog.fpmurphy.com/2010/01/uef...tml?output=pdf

I've read through them and neither really seems to apply to my situation.

A friend suggested doing a Windows install just for the sake of getting the MBR set up and then go back and install Linux as a GPT drive. I don't know if this holds any merit as I believe that re-configuring the drive as GPT would wipe out the MBR anyway.... (again, I may be wrong).

Does anyone have any advice as to what I can try?