Results 1 to 3 of 3

Thread: setting nomodeset with Grub

  1. #1
    Join Date
    Nov 2009

    setting nomodeset with Grub

    I have a machine that has a dual boot configuration with Ubuntu and Slackware and I need nomodeset for both.
    For Ubuntu, I can specify nomodeset in /etc/default/grub, but how can I set it for slackware ?
    Per my undestanding, modifying /boot/grub/grub.cfg isn't a good idea as it gets overridden everytime Grub gets updated, and one option I can think of is modifying 30_os_prober in a way that automatically includes nomodeset for other Linux in grub.cfg.
    or is there any other way to set nomodeset for other OS' in different partitions ?

  2. #2
    Join Date
    Apr 2011
    3rd Rock from the Sun
    Ubuntu Development Release

    Re: setting nomodeset with Grub

    Haven't you installed Slackware-Grub to its own partition? If you did then you should be able to edit the grub file from Ubuntu. I don't use slackware, never have but if it uses grub then it will have /etc/default/grub...

    my two cents.
    "Evolution is Nature's way of issuing upgrades."

  3. #3
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: setting nomodeset with Grub

    Grub2's os-prober reads the grub.cfg or menu.lst or whatever other systems use to create its boot stanza for that system. Do you have nomodeset in the Slackware settings?

    What boot loader does Slackware still use?
    Update, it defaults to Lilo but you can install grub.

    did you add nomodeset and update its lilo install. It looks like it might be this but I am not sure.

    append=" vt.default_utf8=0"
    Lilo installs part of its boot loading into the PBR like Windows. You should be able to chainload to it like you do Windows.

    An alternative is just to create your own boot stanza in 40_custom with the nomodeset included. Just copy the entry os-prober creates into 40_custom and add the nomodeset entry to it.

    Copy the entries from this:
    sudo cp -a /boot/grub/grub.cfg /boot/grub/grub.cfg.backup
    gedit /boot/grub/grub.cfg
    Copy them to and edit :
    gksudo gedit /etc/grub.d/40_custom
    Then do:
    sudo update-grub
    Last edited by oldfred; May 14th, 2013 at 05:40 PM.
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts