Results 1 to 1 of 1

Thread: [qucs][solved] Can't add components since may upgrade(0.16 to 0.17)

  1. #1
    Join Date
    Nov 2004
    Beans
    3

    [qucs][solved] Can't add components since may upgrade(0.16 to 0.17)

    Hello,

    I installed qucs 0.16 on ubuntu 12.10 some months ago thanks to Frans Schreuder ppa.

    Some days ago I apt-get upgraded and qucs 0.17 was installed (still from the ppa).

    Now I can't add components in the main viewport, the mouse cursor is always a 'forbidden' sign. I can add ground and wires through the menu though. On old projects I can copy paste components that are already on the viewport but I can't drag and drop from the left pane.

    I didn't find any 0.16 packages on launchpad and compiling from 0.16 source might be tricky due to the qt-3/qt-4 transition.

    So my question:
    1. Did I miss any new settings in qucs that are locking the viewport somehow ?
    2. Where can I find a working 0.16 'backport' ?
    3. Would upgrading to RR solve my problem ?
    4. Is that within the board guidelines to contact fransfrans(ppa maintainer and qucs admin) so he can have a look at this post ?

    Update:
    I found a deb package of qucs 0.16 on launchpad https://launchpad.net/ubuntu/+source...+build/3518542
    dpkg -i complained about libqt3-mt and apt-get install didn't work so I installed the libqt3-mt I found here https://launchpad.net/ubuntu/quantal...3.8-b-8ubuntu3

    Now qucs 0.16 starts up and run but I can't open old schematics, it complains about 'wrong version: 0.17!'. None of these schematics were created or modifier with 0.17. Also, the interface is coloured with an unsual palish blue. On the plus side I can drag and drop components on the viewport. But I can't open old projects.

    Update:
    A little more forum browsing later:
    http://sourceforge.net/p/qucs/discus...25&page=1#ad75
    I just found out that drag and drop is now working differently from QT3-Version (no drag and drop, but double-click the component and click into schematic).
    Sorry, If I have bothered you.

    ...and solved!
    Last edited by nolan; May 16th, 2013 at 09:46 AM. Reason: solved

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •