Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Howto: Using Compton for tear-free compositing on XFCE or LXDE

  1. #11
    Join Date
    Sep 2012
    Beans
    2

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    Brilliant! Finally no more video tearing!

    I'm on a Xubuntu 12.04 with Nvidia driver v311. Tested with VLC, MPlayer and YouTube (old Flash v11.2.202) - only minor glitches left in YouTube playback, possibly because of streaming jitter rather than vsync problems.

  2. #12
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,282
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    this did not resolve my screen tearing I am getting in minecraft. I am running Xubuntu 14.04 with Nvidia driver 337.25 with an EVGA GTX 760 SC. I think i've now tried every possible solution i came across on the web. Anyone else have any other ideas to solve this tearing i'm getting?

    UPDATE: i hadn't disabled Xubuntu's built in compositing in order to get Compton to work, also the -b switch results in an error so to run compton within Xubuntu 14.04 64bit I just issue compton and that's it. This resolved my tearing I was getting in Minecraft. THANKS
    Last edited by dannyboy79; May 31st, 2014 at 11:26 PM.

  3. #13
    Join Date
    Oct 2011
    Beans
    1

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    Using compton with your configuration did fix all of my tearing problems, but it also caused a LOT of lag when dragging windows. I have an Nvidia GTX 570 with 2.5G of vram, so moving 2D windows around the screen should not have any noticable performance issues. This led me to believe that it was a problem with the settings. So, I messed with the compton config a bit and found a different set of options that worked much better for me:

    Code:
    #--------------------------------
    #-------Backend Settings:--------
    #--------------------------------
    backend = "glx";                 # Use GLX backend for rendering
    vsync = "opengl";                # Use OpenGL to implement vsync
    glx-swap-method = 3;             # Use a triple-buffer
    paint-on-overlay = true;         # Improves performance (usually) and reduces flickering
    glx-no-stencil = true;           # Improves performance
    glx-no-rebind-pixmap = true;     # Improves performance with rapid window changes, might not work with some drivers
    
    
    #--------------------------------
    #--------Shadow Settings:--------
    #--------------------------------
    shadow = true;                   # Enable drawing shadows on windows
    shadow-radius = 8;               # The blur radius for shadows
    shadow-offset-x = -8;            # The horizontal offset for shadows
    shadow-offset-y = -8;            # The vertical offset for shadows
    clear-shadow = true;             # Zero the part of the shadow's mask behind the window, may break some applications
    no-dock-shadow = true;           # Do not draw shadows on docks/panels
    no-dnd-shadow = true;            # Do not draw shadows on DND windows
    shadow-exclude = [               # Do not draw shadows on these specific applications:
       #"! name~=''",
        "n:e:Notification",
        "n:e:Plank",
        "n:e:Docky",
        "g:e:Synapse",
        "g:e:Kupfer",
        "g:e:Conky",
        "n:w:*dockbarx*",
       #"n:w:*Firefox*",
       #"n:w:*Chrome*",
       #"n:w:*Chromium*",
        "class_g ?= 'Notify-osd'",
        "class_g ?= 'Cairo-dock'",
        "class_g ?= 'Xfce4-notifyd'",
        "class_g ?= 'Xfce4-power-manager'"
    ];
    
    
    #--------------------------------
    #--------Fading Settings:--------
    #--------------------------------
    fading = true;                   # Enable fading windows during opacity changes
    fade-delta = 4;                  # The time between steps in a fade in milliseconds
    fade-in-step = 0.03;             # The opacity change between steps while fading in
    fade-out-step = 0.03;            # The opacity change between steps while fading out
    detect-client-opacity = true;    # Prevent opacity from being ignored for some applications
    
    
    #--------------------------------
    #--------Window Settings:--------
    #--------------------------------
    wintypes:                        # Change behavior for these specific types of windows:
    {
        tooltip = { fade = true; shadow = false; };
    };
    

    Although this configuration works very well for me, it might not work well for everyone. Some of the options, such as triple buffering, can dramatically decrease performance on graphics cards without enough vram. Also, I am using the proprietary nvidia driver v331.79. These options might not work well (or at all) with nouveau drivers.

  4. #14
    Join Date
    Jul 2014
    Beans
    9

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    i've notced that when i leave my computer on for a couple of days (maybe 2-3) xorg stays at a high cpu and then UI interaction gets sluggish (slow to move windows, etc)


    i kill and then restart compton then everything is ok again.


    anyone else have this issue and/or know what's happening?

  5. #15
    Join Date
    Feb 2014
    Beans
    19

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    Is there a way of putting exceptions to the "inactive-dim" function? I really like that feature but I don't like the fact that it also affects conky.

  6. #16
    Join Date
    Dec 2012
    Beans
    2

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    I don't mean to resurrect an old thread, but this is still one of the top Google results for using compton with Ubuntu.

    I've packaged the latest version of compton, along with an unmerged pull request of mine that fixes a resource leak, for 15.04, 14.04LTS, and 12.04LTS. My fork of compton is at https://github.com/kelleyk/compton and the PPA is at https://launchpad.net/~kelleyk/+archive/ubuntu/compton.

    Hope this helps someone!

  7. #17
    Join Date
    Dec 2012
    Beans
    2

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    Quote Originally Posted by stkeg View Post
    i've notced that when i leave my computer on for a couple of days (maybe 2-3) xorg stays at a high cpu and then UI interaction gets sluggish (slow to move windows, etc)


    i kill and then restart compton then everything is ok again.


    anyone else have this issue and/or know what's happening?
    This is the resource leak that I mentioned in my previous post. The relevant pull request (https://github.com/chjj/compton/pull/285) describes exactly what the problem was and how I tracked it down. It's fixed in my fork of the repository and in my PPA.

  8. #18
    Join Date
    Dec 2007
    Beans
    8,537
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    Quote Originally Posted by pseudosynaptic View Post
    I don't mean to resurrect an old thread, ...
    Not an issue, IMO, because the last post was from Jan 15 this year

    And this is certainly a thread worth keeping open!
    Shortened urls: See point #11 here. And clicking on them could be risky.
    Use ubuntu-support-status with caution.

  9. #19
    Join Date
    Dec 2007
    Beans
    8,537
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    Quote Originally Posted by Pablo_San_Martn View Post
    Is there a way of putting exceptions to the "inactive-dim" function? I really like that feature but I don't like the fact that it also affects conky.
    It may also be worth asking this as a separate conky question because conky experts could look at your conky code and show you how to get what you want without fiddling with your compton settings.

    I'm not aware of compton affecting my conky which is a brief text-only one-liner.

    Edit:
    Have you looked at https://github.com/chjj/compton/blob...of-conditions? That's quite informative (or just type compton -h in your terminal for information specific to your version of compton).
    Last edited by vasa1; August 12th, 2015 at 07:21 AM.
    Shortened urls: See point #11 here. And clicking on them could be risky.
    Use ubuntu-support-status with caution.

  10. #20
    Join Date
    Dec 2014
    Beans
    122

    Re: Howto: Using Compton for tear-free compositing on XFCE or LXDE

    Hi all,

    I've been using compton with xubuntu 14.04 for long time with a great result, but now I've a new install with a freshly installed Xubuntu 15.10 and have notice some problems.

    Some applications (some games such as torcs) gets blocked when run in fullscreen. I've solve this problem using an script that makes "killall compton" before opening the application and "compton -b" when closing the app.

    The bigger problem comes with Google Chrome, it plays videos correctly in "normal" (windowed) mode, but when I go fullscreen video gets frozen althought audio continues. this problem comes with youtube and other webs that plays videos. I've research a bit and youtube uses by default HTML5, so I've move it to flash using a Chrome addon, result? problem is exacty the same. I suppose it's the same problem that comes with those other applications and has nothing to do with html5 or flash.

    Of course, if I disable compton then videos works great in fullscreen mode and... here comes the most insteresting thing, I've no tearing!. I mean:

    If I disable compton there is tearing on videos played in "non-full-screen" but when go to fullscreen tearing dissapears. It makes me think that Chrome includes now some method to remove tearing in full screen. This should be something good, but it seems to interfere with Compton, so it makes video unplayable in fullscreen.

    I've also try to disable hardware acceleration in chrome, for doing this go to the settings and do this. If I do this then video gets no frozen when go to fullscreen, but then I've a huge tearing even with compton enabled. So, this solution is not ok

    I guess the solution of this problem could be having some way to disable compton when Chrome plays video in fullscreen. How can I do this? I could disable compton when opening chrome and enable again when closing, but it's not desirable since I had no compton in any app (remember, we only wants compton to be disabled when playing a video in full-screen).

    Is there any way to disable compton only with chrome and only when play fullscreen? I wonder if I could configure this in "~/.compton.conf".

    Many thanks to everyone who reads this, I hope someone can help.

    Regards
    Last edited by fkervin; November 24th, 2015 at 06:25 PM.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •