Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: [SOLVED]Enable Numlock after booting - Lubuntu 13.04 / Xubuntu 12.04 LTS

  1. #1
    Join Date
    May 2013
    Beans
    10

    Lightbulb [SOLVED]Enable Numlock after booting - Lubuntu 13.04 / Xubuntu 12.04 LTS

    This solution worked for me on both operating systems. ( Lubuntu 13.04 / Xubuntu 12.04 LTS)

    sudo apt-get install numlockx
    sudo leafpad /etc/lightdm/lightdm.conf
    add the next line at the end
    greeter-setup-script=/usr/bin/numlockx on



    I have installed lubuntu 13.04 and been trying for hours to have the numlock on after booting. The numlock is enabled in the bios, and I tried a lot off ways to get it work. 'https://help.ubuntu.com/community/NumLock' and 'https://help.ubuntu.com/community/Lubuntu/Keyboard'.
    I don't see how I can make it work. Any Ideas? I'm new working with the command line so It isn't unpossible that I made some mistakes.
    Thx.
    Last edited by Koenraads; May 15th, 2013 at 11:23 AM. Reason: Closing thread

  2. #2
    Join Date
    Feb 2013
    Location
    Highway to hell
    Beans
    49
    Distro
    Ubuntu Development Release

    Re: Enable Numlock after booting

    If I recall correctly, on Lubuntu 12.04 I needed to edit lxdm.conf to get Num Lock to activate on startup, or was that Lubuntu 11.04. In any way, run
    Code:
    gksu leafpad /etc/xdg/lubuntu/lxdm/lxdm.conf
    and change the
    Code:
    # numlock=0
    line to
    Code:
    numlock=1
    That did it for me, though I'm not sure if it will work on 13.04.

  3. #3
    Join Date
    May 2013
    Beans
    10

    Thumbs down Re: Enable Numlock after booting

    Hi, I already tried that one but I doesn't work.

  4. #4
    Join Date
    Feb 2013
    Location
    Highway to hell
    Beans
    49
    Distro
    Ubuntu Development Release

    Re: Enable Numlock after booting

    Alright then, there's another way that should work. Try using numlockx to enable it after booting, first run
    Code:
    sudo apt-get numlockx
    to get the package. Then run
    Code:
    gksu leafpad /etc/X11/xinit/xinitrc
    and add
    Code:
    /usr/bin/numlockx on
    to the bottom of the file, below the /etc/X11/Xsession line. That will enable numlock the moment you login to a user account.

  5. #5
    Join Date
    May 2013
    Beans
    10

    Lightbulb Re: Enable Numlock after booting

    Werne,

    I tried it but it didn't work. NumLock is on while booting during bios time but once launched Lubuntu 'the light' gets off.
    This is the file how I changed it:

    #!/bin/sh


    # /etc/X11/xinit/xinitrc
    #
    # global xinitrc file, used by all X sessions started by xinit (startx)


    # invoke global X session script
    . /etc/X11/Xsession
    /usr/bin/numlockx on

    Did I make a mistake?
    Grtz and thanks for your effort!

  6. #6
    Join Date
    Feb 2013
    Location
    Highway to hell
    Beans
    49
    Distro
    Ubuntu Development Release

    Re: Enable Numlock after booting

    Yeah, you did everything right, it's just that it refused to initialize. It should've though, xinitrc should've started it the moment Xsession starts. Well, that's unless you didn't log into your DE and logged into bash, that wouldn't start the Xsession which in turn wouldn't start numlockx either.

    In any way, open the terminal and run the following command while your numlock is off:
    Code:
    numlockx on
    If num lock activates, run
    Code:
    numlockx off
    to turn it off.

    This is just to check if numlockx works like it should, if it does then it's just a matter of finding how to initialize it on startup.

  7. #7
    Join Date
    May 2013
    Beans
    3

    Re: Enable Numlock after booting

    thanks!nice package & tip.

  8. #8
    Join Date
    May 2013
    Beans
    10

    Re: Enable Numlock after booting

    Werne, since I was afraid that I tried maybe to many different things since I installed Lubuntu 3 days ago, I reinstalled it today.
    Unfortunately it didn't help. But there are some problems when I try the sugested commando's.
    This is what happens and I don't really know what it means:

    schoonjans@Vic1:~$ numlock on
    Opdracht ‘numlock’ niet gevonden, bedoelde u:
    Opdracht ‘numlockx’ uit pakket ‘numlockx’ (main)
    numlock: opdracht niet gevonden

    He can't find the commando!

    schoonjans@Vic1:~$ gksu leafpad /etc/xdg/lubuntu/lxdm/lxdm.conf
    GNOME_SUDO_PASS
    sudo: 1 incorrect password attempt


    ** (leafpad:1719): WARNING **: Invalid borders specified for theme pixmap:
    /usr/share/themes/Lubuntu-default/gtk-2.0/images/scrollbar_vertical.png,
    borders don't fit within the image
    schoonjans@Vic1:~$ sudo apt-get numlockx
    E: Ongeldige operatie numlockx
    schoonjans@Vic1:~$ gksu leafpad /etc/X11/xinit/xinitrc


    ** (leafpad:1889): WARNING **: Invalid borders specified for theme pixmap:
    /usr/share/themes/Lubuntu-default/gtk-2.0/images/scrollbar_vertical-sel.png,
    borders don't fit within the image

    You can ignore the incorrect password I mistyped.
    The rest seems a bit weard to me.

  9. #9
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Enable Numlock after booting

    Couple of errors in the commands you ran.
    schoonjans@Vic1:~$ sudo apt-get numlockx
    Left out install
    Code:
    sudo apt-get install numlockx

    schoonjans@Vic1:~$ numlock on
    Left off the x
    Code:
    numlockx on
    Code:
    numlockx off
    Last edited by stinkeye; May 11th, 2013 at 07:50 PM.

  10. #10
    Join Date
    May 2013
    Beans
    10

    Re: Enable Numlock after booting

    Stinkeye, Werne,

    We are making progress. After you're hint (Stinkeye) the command numlockx on and off now works!

    I still get the leafpad: 1729 Warning adjusting the lxdm.conf file.
    When I look into the file after unquoting and changing numlock into 1 the changes are still there. After reboot numlock is still not on.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •