Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 43

Thread: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

  1. #21
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,553
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    I am running out of ideas. Maybe a Mainline-Kernel, version 3.9?! Its running here, too, on 12.04

  2. #22
    Join Date
    Jun 2011
    Beans
    35

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    Quote Originally Posted by praseodym View Post
    I am running out of ideas. Maybe a Mainline-Kernel, version 3.9?! Its running here, too, on 12.04
    Yes it's look like a kernel bug as it's reported in the Launchpad link.
    However it seems only partially corrected.

  3. #23
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    16,725
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    I ran into this bug concerning 9285 a couple of weeks ago and the only way we found around it was to boot an earlier kernel.

    I have a new laptop with 9485 device and it is not effected by the bug just the 9285.

    Hopefully there will be a patch for it soon but there is not one at this time that I know of.

  4. #24
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,553
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    Hi

    I found a "solution". Obviously, S205 does not work (yet) with 13.04. Therefore, I recommend installing 12.04 LTS and changing the boot priority to 1. wireless and 2. Ubuntu.

    http://forum.ubuntuusers.de/topic/na...4#post-5563587

  5. #25
    Join Date
    May 2008
    Beans
    6

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    Ok for me the wifi now works on lenovo s205 running xubuntu 13.04 (did an upgrade from 12.10 and it didnt worked, with same problem as described). My configuration for now is:

    This lines in /etc/rc.local:

    rfkill unblock wifi
    rfkill unblock all
    modprobe -r acer-wmi

    And this line in /etc/modprobe.d/blacklist.conf:

    blacklist acer_wmi

    And than the bios, you need to move the hard drive to the first position before ubuntu, else it doesnt work for me. That is all I have done and I must say that the range and quality is better than before, because I have better signal and can reach wifis that I never discovered before (I am so happy now, almost thought that i have to install a frest previous version of ubuntu). Strange things happen .

  6. #26
    Join Date
    Jun 2011
    Beans
    35

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    What I don't understand is that I don't have these two entries (HDD and Ubuntu) in the boot process, only HDD and PXE.
    So I can't change the order (I've installed three times...)

    Have you installed 13.04 on top of 12.10 or done a fresh install ?

    Firstly I've upgrader but the system was completely bugged, so I've done a fresh install which was not simple.
    I had to do some tweaks like using boot-repair to be able to boot...

  7. #27
    Join Date
    May 2008
    Beans
    6

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    I have upgraded from 12.10 via the software updater in xubuntu. The only problem I had was the wifi not working and some errors on boot up (libkmod- config... something to do with irda-utils.conf). Ive solved this problem, by installing the ATI drivers from their official site.
    Before upgrade my disk was also on first position on boot, but after upgrade i had to change it back, because it changed to second position. It is strange that you dont have this options in bios to change ubuntu with the hard drive, I have 6 options: ATA HDD0: WDC..., Ubuntu, USB HDD,USB CD, USB FDD, PCI LAN: Realtek... Check the setting in bios and also the bios version, I have SATA controller working mode set to AHCI, wireless and usb legacy enabled. It could also be that you have the previous version of this netbook with e-350 processor or different vesion of bios ? Mine is with e-450 processor and 4BCN24WW version of bios if this helps.

  8. #28
    Join Date
    Jun 2011
    Beans
    35

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    It's an e-350 with 4BCN21WW bios version.
    I'll check if I can upgrade it.

  9. #29
    Join Date
    Jun 2011
    Beans
    35

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    Ok...

    Tried to upgrade the BIOS to 4BCN24WW version but with no success.

    I've used the bios downloaded from lenovo web site.
    Extracted the files from a Windows and copied the BIOS1.WPH (renamed to BIOS.WPH) to a USB stick (used the following method : https://s205blog.wordpress.com/2013/...ed-windows-os/).

    It wasn't working, I get "Invalid FlashInt.bin".

    I've been a little crazy and tried to used the old method with the old flash tool that was worked for me before (pflash.exe and not phlash16.exe) but it resulted in a bricked s205...
    Was able to recover it using Fn-R method.

    But I'm still unable to update it

  10. #30
    Join Date
    Jun 2011
    Beans
    35

    Re: 13.04 / Lenovo S205 / WIFI / Atheros / Ath9k

    Hi,

    I finally was able to upgrade my bios (done some tricks thru an UBCD4WIN)...
    But this was no help.

    I've just upgraded to kernel 3.10-rc2 and finally the wifi is no more hard blocked !
    > https://bugs.launchpad.net/bugs/1173681

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •