Results 1 to 3 of 3

Thread: Ubuntu 13.04 2009_1110_RT3070_Linux_STA_v2.1.2.0.tar.bz2

  1. #1
    Join Date
    May 2013

    Ubuntu 13.04 2009_1110_RT3070_Linux_STA_v2.1.2.0.tar.bz2

    I recently bought asus - ieee 802.11n usb - wi-fi adapter for my Dell Latitude e6400 running Ubuntu 13.04 Raring Ringtail.

    My objective is to upgrade my wireless card, because for some reason my wireless card shuts off after a lot of stress.

    I was following these instructions:

    1.)Download the driver from #17 by chili555(2009_1110_RT3070_Linux_STA_v2.1.2.0)
    2.)Extract it to your Desktop (or anywhere, but I used thatone)
    Basicallyif you double-click on it the Archive Manager will start and you needto choose where to Extract.
    3.)Go to the folder

    (obviouslyit will ask for your sudo/administrator password)

    6.)Create two files in the next steps:

    thenwhen the text editor opens up
    copyand paste the followings exactly as it is. case and all, quotes andall:

    ACTION=="add",SUBSYSTEM=="usb", ATTR{idVendor}=="0b05",ATTR{idProduct}=="1784", RUN+="/sbin/modprobe -qbart3070sta"
    saveand close the text editor.
    thecopy and paste as above:
    installrt3070sta /sbin/modprobe --ignore-install rt3070sta $CMDLINE_OPTS;/bin/echo "0b05 1784" >/sys/bus/usb/drivers/rt2870/new_id
    saveand close text editor.
    7.)plug the USB device in (mine wasn't recognized until Irestarted...)
    8.)exit terminal window
    9.)restart system
    10.)configure your wireless

    Ihope I didn't miss anything... Good luck.

    PS:it's worth to mention that I had to fiddle with the router, toobecause for some reason it just didn't let the USB to connect, I ranthe router's connection wizard and that solved my last problem.

    And when I tried sudo make, I received this:

    tony@tony-Latitude-E6400:~/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0$ sudo make
    [sudo] password for tony:
    make -C tools
    make[1]: Entering directory `/home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/tools'
    gcc -g bin2h.c -o bin2h
    make[1]: Leaving directory `/home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/tools'
    cp -f os/linux/Makefile.6 /home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/Makefile
    make -C /lib/modules/3.8.0-20-generic/build SUBDIRS=/home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux modules
    make[1]: Entering directory `/usr/src/linux-headers-3.8.0-20-generic'
    CC [M] /home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/../../common/rtmp_init.o
    /home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/../../common/rtmp_init.c: In function ‘RtmpRaDevCtrlInit’:
    /home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/../../common/rtmp_init.c:3709:2: error: implicit declaration of function ‘init_MUTEX’ [-Werror=implicit-function-declaration]
    /home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/../../common/rtmp_init.c:3710:2: warning: passing argument 2 of ‘os_alloc_mem’ from incompatible pointer type [enabled by default]
    In file included from /home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/include/rt_config.h:57:0,
    from /home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/../../common/rtmp_init.c:37:
    /home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/include/rtmp.h:5704:13: note: expected ‘UCHAR **’ but argument is of type ‘UCHAR *’
    cc1: some warnings being treated as errors
    make[2]: *** [/home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/../../common/rtmp_init.o] Error 1
    make[1]: *** [_module_/home/tony/Desktop/2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-3.8.0-20-generic'
    make: *** [LINUX] Error 2

    Any help? I don't receive the actual adapter for another 5 days or so, but I wanted to go ahead and install the drivers so that I could just plug and play.

  2. #2
    Join Date
    Aug 2005
    South Carolina, USA
    Ubuntu 17.04 Zesty Zapus

    Re: Ubuntu 13.04 2009_1110_RT3070_Linux_STA_v2.1.2.0.tar.bz2

    This driver and the process described are far too old for Ubuntu 13.04:
    As a matter of fact, this device should plug and play using the built in driver rt2800usb with no further steps. Please post back if not.

    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    May 2013

    Re: Ubuntu 13.04 2009_1110_RT3070_Linux_STA_v2.1.2.0.tar.bz2

    It works perfectly! No setup just plug and play. I had seen some people had some problems when I went looking around. Speed is twice as fast. I'd recommend this to anyone!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts