Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: Disabled wireless on ASUS U32U

  1. #21
    Join Date
    May 2013
    Beans
    8

    Re: Disabled wireless on ASUS U32U

    Please wait for me. This u32u is my wife's computer which I brought her so now I can use her's older one.In the evening - here I'm going to construct and attach the file.
    Thanks for reply

  2. #22
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Disabled wireless on ASUS U32U

    Quote Originally Posted by jdominik View Post
    Please wait for me. This u32u is my wife's computer which I brought her so now I can use her's older one.In the evening - here I'm going to construct and attach the file.
    We'll be right here.. awaiting

    If the main problem is of the same nature (wireless switches on momentarily, then turns off again), with references to asus_wmi in dmesg part of the generated report, you can safely try the blacklisting trick that worked for john1113. As mentioned in my last post, it can be quickly and easily reverted if doesn't work.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  3. #23
    Join Date
    May 2013
    Beans
    8

    Re: Disabled wireless on ASUS U32U

    My new netinfo file...
    Attached Files Attached Files

  4. #24
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Disabled wireless on ASUS U32U

    Hardware switch is okay, but ath9k is not loaded. Strange.

    You said in post #6 that you now have to do 'sudo modprobe ath9k' everytime you boot. Do you get connected after that? Or is there anything even worse?

    If manually modprob'ing the ath9k module gets you connected, try-
    Code:
    sudo modprobe -v ath9k
    sudo update-initramfs -u
    ..then reboot. Does ath9k load automatically after reboot? (check - lsmod | grep ath)

    If not, we can force it by adding it to /etc/modules file -
    Code:
    echo ath9k | sudo tee -a /etc/modules
    Does it make life any better?
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  5. #25
    Join Date
    May 2013
    Beans
    8

    Re: Disabled wireless on ASUS U32U

    This makes life better:
    Code:

    echo ath9k | sudo tee -a /etc/modules
    And instruction with whick my wireless is still enabled:


    echo "blacklist asus_nb_wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf

    But it also disabled my volume keywords... so what if I want to enabled this? They're very usefull so...

  6. #26
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Disabled wireless on ASUS U32U

    Quote Originally Posted by jdominik View Post
    This makes life better:
    Code:

    echo ath9k | sudo tee -a /etc/modules
    It shouldn't have been required in the first place, so apparently we seem to have some messed up configuration requiring us to force it. But anyway, as long as it works....

    And instruction with whick my wireless is still enabled:

    echo "blacklist asus_nb_wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf

    But it also disabled my volume keywords... so what if I want to enabled this? They're very usefull so...
    In the netinfo.txt file you attached, the hardware key looked okay, so the above blacklisting shouldn't have been required. Was the wireless switched off again after force-loading ath9k as above? Please confirm.

    As of now, please try -
    Code:
    sudo modprobe -v asus_nb_wmi
    ..and see if the volume control works again. If it doesn't, or if the Fn+ key combinations start working strangely, please run a module unload/load cycle -
    Code:
    sudo modprobe -rfv asus_nb_wmi
    sudo modprobe -v asus_nb_wmi
    Does everything start working as expected? (may take a few seconds to a minute, plus a few random Fn key combos initially).
    Or is something still falling apart?

    If the above cycle makes everything normal, we may remove the blacklisting above to make this normality permanent.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  7. #27
    Join Date
    Aug 2013
    Beans
    1

    Re: Disabled wireless on ASUS U32U

    I got the same problem on my Asus U32U with AMD E450 APU.
    The solution I found was to go in "suspend-mode" and wake it up again.. Then the Wifi will work. Untill the next time I reboot and I have to suspend and wake up again.

    Does anyone have a better and permanent solution for this?


    Mvh
    Martin

  8. #28
    Join Date
    Oct 2013
    Beans
    2

    Re: Disabled wireless on ASUS U32U

    Quote Originally Posted by Martin_Solstad View Post
    I got the same problem on my Asus U32U with AMD E450 APU.
    The solution I found was to go in "suspend-mode" and wake it up again.. Then the Wifi will work. Untill the next time I reboot and I have to suspend and wake up again.

    Does anyone have a better and permanent solution for this?


    Mvh
    Martin
    I've exactly the same problem with my Asus U32U. Tried all major distros, and I get the same problem. It's annoying.

  9. #29
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Disabled wireless on ASUS U32U

    Welcome to the forums bndMfbF!

    And thanks for bumping the thread, I had forgotten this one.

    I think I have recently found a better solution (workaround, without any compromises) than blacklisting asus_nb_wmi. Please try this and let us all know whether it works or not for you : http://ubuntuforums.org/showthread.p...1#post12805891

    Look at post#32 below the linked post to see a nicely listed progress report from shao2.

    NOTE: If you have not blacklisted the "asus_nb_wmi" driver, you don't need the 2nd command in the post - "sudo sed -i '/asus_nb_wmi/ d' /etc/modprobe.d/blacklist.conf".

    Of the three people who tried this so far (in my knowledge), it worked for two, but the third (actually the first with whom we tried it, thanks to chili555) actually had the opposite problem - he couldn't turn his wifi off. So from the point of view of "making wifi work", it seems to work for all.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  10. #30
    Join Date
    Oct 2013
    Beans
    2

    Re: Disabled wireless on ASUS U32U

    Quote Originally Posted by varunendra View Post
    Welcome to the forums bndMfbF!

    And thanks for bumping the thread, I had forgotten this one.

    I think I have recently found a better solution (workaround, without any compromises) than blacklisting asus_nb_wmi. Please try this and let us all know whether it works or not for you : http://ubuntuforums.org/showthread.p...1#post12805891

    Look at post#32 below the linked post to see a nicely listed progress report from shao2.

    NOTE: If you have not blacklisted the "asus_nb_wmi" driver, you don't need the 2nd command in the post - "sudo sed -i '/asus_nb_wmi/ d' /etc/modprobe.d/blacklist.conf".

    Of the three people who tried this so far (in my knowledge), it worked for two, but the third (actually the first with whom we tried it, thanks to chili555) actually had the opposite problem - he couldn't turn his wifi off. So from the point of view of "making wifi work", it seems to work for all.
    Good evening

    Thank you very much. It's working!! Started to work after changing to wapf=1 and rebooting.

    Too bad I've to send the laptop in a few days for warranty. Screen problems

    And again, awesome job.

    Cheers, Filipe

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •