Results 1 to 5 of 5

Thread: How to Mount ext4 With Full RW Permissions?

  1. #1
    Join Date
    May 2013

    How to Mount ext4 With Full RW Permissions?

    Hello all, I'm having trouble getting a partition to mount with rw permissions for all users (though, there is only me). There are two partitions that I want mounting on boot, the first is a ntfs which mounts ok with full rw permissions. The second is a ext4 partition.

    I used the program "disks" to automount them on boot, so the options were generated by it.

    /dev/disk/by-uuid/A4B0266BB0264460 /media/Data auto nosuid,nodev,nofail,x-gvfs-show 0 0
    #/dev/disk/by-uuid/8ab85d88-a053-4e2c-a6ac-47268da18bd6 /media/linuxData auto rw,user,nosuid,nodev,uhelper=udisks2 0 0
    /dev/disk/by-uuid/8ab85d88-a053-4e2c-a6ac-47268da18bd6 /media/linuxData auto defaults 0 0
    The windows partition mouned ok but the ext4 wouldn't and halted the boot process. I eventually removed "nofail,x-gvfs-show" and the partition mounted but only with rw permissions for root.

    I used the "mount" command to find out what options the partitions are actually mounted with, and they aren't exactly the same as those in the fstab, so I tried adding them to the fstab too ... with no luck!

    /dev/sda5 on / type ext4 (rw,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/cgroup type tmpfs (rw)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    udev on /dev type devtmpfs (rw,mode=0755)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
    none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
    none on /run/shm type tmpfs (rw,nosuid,nodev)
    none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
    /dev/sda3 on /media/Data type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    /dev/sda9 on /media/linuxData type ext4 (rw,noexec,nosuid,nodev,uhelper=udisks2)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    gvfsd-fuse on /run/user/slimline/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=slimline)
    I've also tried changing "user" to "user=slimline"; manually setting the "linuxData" directory permissions then rebooting (they get changed back to "access only" on reboot!); and finally, using only "defaults" as the options.

    I have another linux distro installed too and when manually mounting them it's the same, the ext4 partiton mounts as read only for all except root.

    I'm using Ubuntu 13.04 btw.
    I'm new to linux (a couple of weeks) and am now at a loss for ideas.

    Last edited by slimline66; May 5th, 2013 at 01:37 PM. Reason: Updated prefix

  2. #2
    Join Date
    Jul 2005
    I think I'm here! Maybe?

    Re: How to Mount ext4 With Full RW Permissions?

    You need to change the permissions of the mount folder of the ext4 partition to allow either just you or perhaps anyone to read/write with the command
    sudo chown username:username /path/to/mountpoint
    editing the italics above to fit your system.

    For all users to have read/write you need to use
    sudo chmod 777 /path/to/mountpoint
    DISTRO: Xubuntu 16.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info

  3. #3
    Join Date
    May 2013

    Re: How to Mount ext4 With Full RW Permissions?

    Thank you brother, chown did it!

    Any idea why I had to go through this extra step? ... none of the tutorials on yt or the web mentioned it.

    Also, is it best to take owership of the ntfs mountpoint/directory as root still owns it, although granting rw permissions?

  4. #4
    Join Date
    Dec 2009

    Re: How to Mount ext4 With Full RW Permissions?

    There are 2 advantages to taking possession of the mounted ntfs partition but it depends on how you are using it:

    ** Sending something to the trash will not result in an error message.
    ** Makes it easier to create a Samba share as a regular user if you own the mounted partition and want to share it with others in the network.

    Can't use a chown on it however you need to add a "uid=1000" to the list of options instead. And I'm assuming you are uid=1000. To find out run the following command:

  5. #5
    Join Date
    Apr 2005
    Ubuntu 16.04 Xenial Xerus

    Re: How to Mount ext4 With Full RW Permissions?

    It's not really an extra step as such, it's just that Ext filesystems support Linux file/directory ownerships and permissions, and therefore their ownership can be handled just like any other file or directory on your system.

    It's the NTFS partition that needs the extra step of configuring the permissions at mount time for the whole partition (through fstab) since NTFS isn't able to handle the permissions on it's own.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts