Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Problems booting with 13.04 on PPC

  1. #1
    Join Date
    Feb 2011
    Beans
    204

    Problems booting with 13.04 on PPC

    Hi. I've been trying to load live cd's with 13.04 on my PowerPC mac. I've tried with Kubuntu and Lubuntu lice cd's. However, after the splash screen, booting freezes on a black screen with some messages, where the last one states "Stoping mount network filesystems".

    The only thing I can do is to enter a terminal prompt with Ctrl+Alt+F1.

    I currently have Kubuntu 12.04 installed on the machine, and that works well. I should add that the same problem has happened once when I tried to upgrade from 12.04 to 12.10 (which, at that time, forced me to reinstall 12.04).

    Any help?
    Linux Mint 17.3 running on my AMD A8-6600K desktop; .Ubuntu 15.10 running on a Intel i5 6200U @2.30 GHz laptop

  2. #2
    Join Date
    Apr 2013
    Beans
    27

    Re: Problems booting with 13.04 on PPC

    Quote Originally Posted by canhoto View Post
    Hi. I've been trying to load live cd's with 13.04 on my PowerPC mac. I've tried with Kubuntu and Lubuntu lice cd's. However, after the splash screen, booting freezes on a black screen with some messages, where the last one states "Stoping mount network filesystems".

    The only thing I can do is to enter a terminal prompt with Ctrl+Alt+F1.

    I currently have Kubuntu 12.04 installed on the machine, and that works well. I should add that the same problem has happened once when I tried to upgrade from 12.04 to 12.10 (which, at that time, forced me to reinstall 12.04).

    Any help?
    Lubuntu 13.04 PPC requires one to enter boot parameters at the yaboot prompt in order to boot the Live CD, depending on the video card you're running. I have booted it successfully with Radeon cards in a Sawtooth, MDD and iBook G4. What video card are you running?

    FYI, so far, I have been unsuccessfull in booting regular Ubuntu 13.04 on any of my Powermacs.

  3. #3
    Join Date
    Feb 2011
    Beans
    204

    Re: Problems booting with 13.04 on PPC

    Quote Originally Posted by michiganmac View Post
    What video card are you running?
    I have a NVIDIA GeForce 6200. What boot parameters should I insert?
    Linux Mint 17.3 running on my AMD A8-6600K desktop; .Ubuntu 15.10 running on a Intel i5 6200U @2.30 GHz laptop

  4. #4
    Join Date
    Apr 2013
    Beans
    27

    Re: Problems booting with 13.04 on PPC

    Quote Originally Posted by canhoto View Post
    I have a NVIDIA GeForce 6200. What boot parameters should I insert?
    OK, here's what works on my Sawtooth, with an nVidia gForce4 MX 64MB card installed. I used a usb flash drive attached to a USB 2 PCI card, and was connected to the internet via ethernet cable. I don't know if it will work for your nVidia card--that's a flashed pc card, right? Anyway, I just verified it works with mine. I was able to boot to the live desktop and everything ran normally.

    I got some of this from the "Known Problems" wiki.

    At the yaboot prompt, type:

    live video=offb:off nouveau.modeset=0 single

    This will freeze the screen or give a blank screen. Mine freezes at the screen when the video card is recognized. That's ok. You have to judge when the machine has finished booting, which can be longer than you think. I waited until the flash drive stoppped blinking fast for at least 60 seconds. For the next step, you will not be able to see what you're typing, so take it slow so you make no mistakes.

    Now type:

    modprobe nvidiafb mode_option=1920x1080-32

    Substitute your monitor's screen resolution (where I typed 1920x1080-32). When you hit the return key, you will find yourself in a terminal screen.

    Now type this:

    start lightdm

    In 30 seconds or so, you should be looking at the booted desktop.

    I know this sounds complicated, but it's really only three steps:

    live video=offb:off nouveau.modeset=0 single

    modprobe nvidiafb mode_option=1920x1080-32

    start lightdm

    This worked perfectly for me. I hope it works for you. Please let us know. Good luck!

  5. #5
    Join Date
    Feb 2013
    Beans
    52

    Re: Problems booting with 13.04 on PPC

    Ok Michigan Mac, I did as you told here and it went ok.
    I put my resolution 1680x1050-32 it says is a 32 bit color so I went direct to the start screen and then to the desktop, everything good so far, but I cannot install the system. Even though I have an extra internal hd with 150GB of free space (the original HD of the g5 i have)
    I have a g5 dual 2.0ghz 1gb memory and nvidia geforce 6600 PCIe so what is making this program don't want to install it? someone help me

    Gus

  6. #6
    Join Date
    Apr 2013
    Beans
    27

    Re: Problems booting with 13.04 on PPC

    Quote Originally Posted by gusduenas View Post
    Ok Michigan Mac, I did as you told here and it went ok.
    I put my resolution 1680x1050-32 it says is a 32 bit color so I went direct to the start screen and then to the desktop, everything good so far, but I cannot install the system. Even though I have an extra internal hd with 150GB of free space (the original HD of the g5 i have)
    I have a g5 dual 2.0ghz 1gb memory and nvidia geforce 6600 PCIe so what is making this program don't want to install it? someone help me

    Gus
    Hi Gus. I'm sorry, but the instructions I wrote above are what worked for me when installing Lubuntu 13.04 on a Powermac G4. I don't have a G5, or any experience on a G5. Hopefully, someone else will be able to help you with that.

  7. #7
    Join Date
    Feb 2013
    Beans
    52

    Re: Problems booting with 13.04 on PPC

    thanks man, but do install lubuntu on the mac g4...but why it is stalling or not even completing the installation on mac g5.... strange ins't.

  8. #8
    Join Date
    Feb 2011
    Beans
    204

    Re: Problems booting with 13.04 on PPC

    Quote Originally Posted by michiganmac View Post
    OK, here's what works on my Sawtooth, with an nVidia gForce4 MX 64MB card installed. I used a usb flash drive attached to a USB 2 PCI card, and was connected to the internet via ethernet cable. I don't know if it will work for your nVidia card--that's a flashed pc card, right? Anyway, I just verified it works with mine. I was able to boot to the live desktop and everything ran normally.

    I got some of this from the "Known Problems" wiki.

    At the yaboot prompt, type:

    live video=offbff nouveau.modeset=0 single

    This will freeze the screen or give a blank screen. Mine freezes at the screen when the video card is recognized. That's ok. You have to judge when the machine has finished booting, which can be longer than you think. I waited until the flash drive stoppped blinking fast for at least 60 seconds. For the next step, you will not be able to see what you're typing, so take it slow so you make no mistakes.

    Now type:

    modprobe nvidiafb mode_option=1920x1080-32

    Substitute your monitor's screen resolution (where I typed 1920x1080-32). When you hit the return key, you will find yourself in a terminal screen.

    Now type this:

    start lightdm

    In 30 seconds or so, you should be looking at the booted desktop.

    I know this sounds complicated, but it's really only three steps:

    live video=offbff nouveau.modeset=0 single

    modprobe nvidiafb mode_option=1920x1080-32

    start lightdm

    This worked perfectly for me. I hope it works for you. Please let us know. Good luck!
    Great! It worked!

    I was really astonished about how quick Lubuntu can be - even when running from a CD!

    The question is: if I install it, will I have to make all this at each boot?

    Thanks!
    Linux Mint 17.3 running on my AMD A8-6600K desktop; .Ubuntu 15.10 running on a Intel i5 6200U @2.30 GHz laptop

  9. #9
    Join Date
    Feb 2013
    Beans
    52

    Re: Problems booting with 13.04 on PPC

    hey let me know if you can install it, so far the installer crashes at 88% of the files being copied, using Kubuntu 13.04 on g5 ppc with nvidia geforce 6600 256mb, also rekong crashes too, and firefox is not installing...any ideas, let me know if you can install it.

  10. #10
    Join Date
    Apr 2013
    Beans
    27

    Re: Problems booting with 13.04 on PPC

    Quote Originally Posted by canhoto View Post
    Great! It worked!

    I was really astonished about how quick Lubuntu can be - even when running from a CD!

    The question is: if I install it, will I have to make all this at each boot?

    Thanks!
    Great! Glad to see it worked.

    I've never done a full install on the Sawtooth with the nVidia card. I've only done full installs with Radeon 9000 Pro and Radeon 9800 Pro cards. I only installed the nVidia card to test the live CD for you.

    With Radeon cards, once the full installation is done, the computer boots normally with no extra boot parameters needed. I think it will work the same way for the nVidia cards, but I can't say for sure because I haven't actually done it. So, you'll just have to try it and see.

    If you go ahead with the full installation, check the option box that allows the installer to automatically download updates from the internet while it is doing the installation. If it works for you, let us know, and then mark the thread as solved.

    Nice job, and good luck with the full installation!

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •