Results 1 to 5 of 5

Thread: Two hdd NTFS "Move to Trash" is placed only on one hdd context menu.

  1. #1
    Join Date
    Jan 2010
    Beans
    36

    [SOLVED] Two hdd NTFS "Move to Trash" is placed only on one hdd context menu.

    Ubuntu 13.04

    Two hdd with NTFS partitions. I use pysdm for automount.
    Same adjustment on both HDD.
    http://db.tt/Oc5MJyS2

    "HDD sdb" - with "Move to Trash" can delete with delete key, and from right click context menu ("Move to Trash" + "Delete").
    http://db.tt/WBOMBH2L

    "HDD sdc" - with no "Move to Trash" canot delet with delete key. Only can delet with right click "Delete" (no have "Move to Trash").
    http://db.tt/DuC9UTWF

    Cut, Copy, Paste work on both.

    When I make synbolic link from "HDD sdc" to "Home folder", and go through "Home folder" to "HDD sdc" - "Move to Trash" is OK, placed in right click context menu, and can delet with "Delete" key.
    Regards some ideas.
    Last edited by erngab; May 5th, 2013 at 12:37 AM. Reason: [SOLVED]

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Two hdd NTFS "Move to Trash" is placed only on one hdd context menu.

    Generally pysdm, does not add good mount options.

    Better to follow this advice, you should be able to edit current entries to match.

    http://ubuntuforums.org/showthread.php?t=1983336
    Mount & edit fstab from Morbius1 - suggest using templates instead. Post #6
    For ntfs UUID shown is example only see below:
    UUID=DA9056C19056A3B3 /media/WinD ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0
    Window_names prevents the use of invalid windows characters:
    (which are the nine characters ” * / : < > ? \ | and those whose code is less than 0×20)
    uid=1000 should fix the trash problems as well:

    ** To find the correct UUID for your partitions:
    sudo blkid -c /dev/null -o list
    ** You will have to create the mount point yourself, for example:
    sudo mkdir /media/WinD
    and/or
    sudo mkdir /media/Data
    ** Then add the template with the correct UUID and mount point to fstab:
    sudo cp /etc/fstab /etc/fstab.backup
    gksu gedit /etc/fstab

    ** And when you are done editing fstab and saving it run the following command to test for errors and mount the partitions without requiring a reboot. You will know before you reboot if something is amiss. Make sure you have partition unmounted if prevously mounted:
    sudo mount -a
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Dec 2009
    Beans
    5,993

    Re: Two hdd NTFS "Move to Trash" is placed only on one hdd context menu.

    Quote Originally Posted by erngab View Post
    Ubuntu 13.04

    Two hdd with NTFS partitions. I use pysdm for automount.
    Quote Originally Posted by oldfred View Post
    Generally pysdm, does not add good mount options.
    Especially since there is no pysdm in the ubuntu 13.04 repositories.

  4. #4
    Join Date
    Jan 2010
    Beans
    36

    Re: Two hdd NTFS "Move to Trash" is placed only on one hdd context menu.

    I got "Move to Trash" and "Delete" key functionality, with this metod on all NTFS partition.


    Thanks a lot Oldfred.

  5. #5
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Two hdd NTFS "Move to Trash" is placed only on one hdd context menu.

    Thank Morbius1 as it is his post in the original thread.
    Glad you got it working.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •