Results 1 to 8 of 8

Thread: Kubuntu 13.04 upgrade and wireless led, Atheros AR8152

  1. #1
    Join Date
    Oct 2008
    Beans
    13
    Distro
    Ubuntu 8.04 Hardy Heron

    [SOLVED]13.04 upgrade and wireless led, Atheros AR9285

    Hi everybody,
    I've just switched to Kubuntu 13.04 from 12.10 and i notice that the wireless led of my asus 1011 netbook does'n work. The wireless interface seems to work correctly because i can turn it on and off using the fn+F2 hotkey but the indicator led doesn't turn off.

    i don't even undersand where the problem is; kernel? acpi?
    i have an Atheros wireless card (AR8152).

    thanks
    Last edited by B&Co; May 3rd, 2013 at 11:31 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Kubuntu 13.04 upgrade and wireless led, Atheros AR8152

    Are you sure AR8152 isn't ethernet? What does this tell us?
    Code:
    lspci -nn | grep 0280
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Oct 2008
    Beans
    13
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Kubuntu 13.04 upgrade and wireless led, Atheros AR8152

    You're right chili555, i red the wrong part of lshw. My wifi card is a AR9285 (PCI-express)
    here the lspci output

    Code:
    02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    Anyway... is my problem a wireless card problem? I mean: isn't the wifi led managed by the os?

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Kubuntu 13.04 upgrade and wireless led, Atheros AR8152

    is my problem a wireless card problem? I mean: isn't the wifi led managed by the os?
    It's complicated. There is usually a laptop-mode or similar module that converts all the laptop key presses, Fn+F10, for example, into action the kernel can use. It's referred to as laptop-mode because such things are unique to laptops and not desktops nor tablets, phones, Raspberry Pi, etc. Also, some, not all, drivers have a method to change the behavior of the LED. Your wireless driver is among them:
    $ modinfo ath9k
    filename: /lib/modules/3.8.0-19-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
    license: Dual BSD/GPL
    description: Support for Atheros 802.11n wireless LAN cards.
    author: Atheros Communications
    srcversion: 99BC2D0E2F8B67646D6C273
    <snip>
    parm: nohwcrypt:Disable hardware encryption (int)
    parm: blink:Enable LED blink on activity (int)
    parm: btcoex_enable:Enable wifi-BT coexistence (int)
    parm: enable_diversity:Enable Antenna diversity for AR9565 (int)
    That may, in fact, not be what you are looking for, but let's test it temporarily:
    Code:
    sudo modprobe -r ath9k
    sudo modprobe ath9k blink=1
    Any improvement?

    Let's see which of the several laptop-mode modules are loaded for your machine:
    Code:
    lsmod | grep asus
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Oct 2008
    Beans
    13
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Kubuntu 13.04 upgrade and wireless led, Atheros AR8152

    Thanks for your reply chili555!
    Unfortunately the modprobe command seems to have no effect. The hotkey still works but the led does not change. I also tried to change the blink option to "0". No changes anyhow...

    that's the output of the lsmod
    Code:
    $ lsmod | grep asus
    asus_wmi               23517  1 eeepc_wmi
    sparse_keymap          13658  1 asus_wmi
    video                  18894  2 i915,asus_wmi
    wmi                    18590  1 asus_wmi

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Kubuntu 13.04 upgrade and wireless led, Atheros AR8152

    Sadly, asus-wmi gives us no options:
    $ modinfo asus-wmi
    filename: /lib/modules/3.8.0-19-generic/kernel/drivers/platform/x86/asus-wmi.ko
    license: GPL
    description: Asus Generic WMI Driver
    author: Corentin Chary <corentin.chary@gmail.com>, Yong Wang <yong.y.wang@intel.com>
    srcversion: 62CA511243680BE13E8641A
    depends: sparse-keymap,wmi,video
    intree: Y
    vermagic: 3.8.0-19-generic SMP mod_unload modversions
    I am sorry, I know of nothing else to try.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Oct 2008
    Beans
    13
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Kubuntu 13.04 upgrade and wireless led, Atheros AR8152

    Thanks anyway! I'll make some more searches...

  8. #8
    Join Date
    Oct 2008
    Beans
    13
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Kubuntu 13.04 upgrade and wireless led, Atheros AR8152

    SOLVED!!
    I just added
    Code:
    acpi_osi=Linux
    to the /etc/default/grub file.
    Now the wifi led turns on and off accordingly to the hotkey press.

    Unfortunately the hotkey for disabling the touchpad doesn't work now... I'll investigate...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •