Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Grub Failure on 13.04 EFI Installation

  1. #11
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub Failure on 13.04 EFI Installation

    It looks like have both BIOS on UEFI installs. Probably only on is configured correctly to boot.

    You should grub in gpt's protective MBR and the efi partition with grub boot files.

    So depending on settings in UEFI/BIOS you may be booting one way or the other.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  2. #12
    Join Date
    May 2010
    Location
    Seattle, WA
    Beans
    38

    Re: Grub Failure on 13.04 EFI Installation

    Not sure what you mean by grub in gpt's protective MBR. I did upgrade from 12.10 to 13.04 and it is working fine. As I mentioned before, when I install from 13.04 CD or USB it fails. I have attached a copy of my BIOS and as you see under Boot Configuration, UEFI Boot [Enabled]. Also note Boot Option #1 ===>>> is set to [ubuntu]. Ground up Installation from 13.04 CD will not give me this option. Any idea why that is?
    Attached Images Attached Images

  3. #13
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub Failure on 13.04 EFI Installation

    The only reason I can think of is that you are not booting Live installer in UEFI mode. It installs in mode (UEFI or BIOS) you boot from.
    Is the 13.04 CD a CD, it is too large and needs to be a flash drive or DVD. And you have to be sure to download the 64 bit version as the 32 bit only installs in BIOS mode.

    If you get a standard grub menu then you are booting installer in UEFI mode as it uses grub to boot.
    If you get the accessibility screen (tiny keyboard & person at bottom of screen) then you are in BIOS mode as it boots with syslinux.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #14
    Join Date
    May 2010
    Location
    Seattle, WA
    Beans
    38

    Re: Grub Failure on 13.04 EFI Installation

    Yes you are correct, it is a 64 bit DVD and I boot in UEFI mode ( no tiny keyboard & person at bottom of screen ). Perhaps my DVD is not good, Indeed it is very strange, I have done this with a Flash Drive as well with the same result.
    I'll repeat the process again -- get the new 64 bit ISO, burn to a new DVD and re-install. I'll report back after I done that.

    Thanks again for support.

  5. #15
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub Failure on 13.04 EFI Installation

    Are you booting but just get a black screen? The first time that happened to me, I only knew it was still booting as USB flash drive was still flickering & I knew it was still loading, but it had turned monitor off. I have nVidia and have had to use nomodeset since about 10.04 for all live installs and on first boot or until I install the nVidia proprietary driver.

    With UEFI you boot with grub, so adding nomodeset is like first boot or you have to edit linux line in grub using e to get to entire boot stanza in grub menu.

    How to set NOMODESET and other kernel boot options in grub2 - both liveCD & first boot, but different
    http://ubuntuforums.org/showthread.php?t=1613132
    https://help.ubuntu.com/community/BootOptions
    Graphics Resolution- Upgrade /Blank Screen after reboot mega thread - MAFoElffen
    http://ubuntuforums.org/showthread.php?t=1743535
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #16
    Join Date
    May 2010
    Location
    Seattle, WA
    Beans
    38

    Re: Grub Failure on 13.04 EFI Installation

    No, I do not have any graphics issue or black screen. Installing Ubuntu 12.10 adds a third Option which is called "ubuntu" to the options for booting (the other 2s are being from DVD and Hard Drive). Please have a look at the previous picture.
    Now after the installation of 13.04 which almost exactly the same steps, I do not get that third Option. Not sure why that is, for now I'll go ahead and mark this as Solved. What I really ended up doing was installed 12.10 UEFI mode successfully then Upgraded to 13.04. It is running just fine for now. Thanks again for all your support...

  7. #17
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub Failure on 13.04 EFI Installation

    Glad you got it working.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •