Results 1 to 6 of 6

Thread: Toshiba L750d/755d kernel & ACPI issues

Threaded View

  1. #1
    Join Date
    Mar 2011
    Beans
    19
    Distro
    Ubuntu

    Toshiba L750d/755d kernel & ACPI issues

    i have a Toshiba L755D (exact same bios (Insyde H2O and hardware as 750d (750d has bluetooth), hence the title) and the Fn keys don't work, no surprise there. i see a bunch of threads in google on other forums, but i cannot find a solution. apparently one that works, is compiling a new kernel, but the most recent one i have seen to do this with is kernel version 2.6. there don't seem to be any other fixes for this problem. i have tried everything else i have see, but if you have seen/see something that i missed please reply.

    i have tried:
    • FnFx (way outdated for older toshiba computers)
    • Toshset (also outdated, but not as much)
    • editing the grub menu (no change, but idk if i did it right, all seem to be for other ubuntu versions/grub versions)

    if you know of anymore, or have seen a fix, please post here.

    Im running Ubuntu 13.04 (have same issues on openSUSE 12.3, Ubuntu 12.04, 12.10) running 64 bit versions, all hardware (except battery) work fine.

    problems:
    • no battery icon (have tried 3rd party software, battery isn't even detected.) but lasts for ~4 hours
    • Fn Keys don't work except Mute(Fn+Exc) volume up/down (Fn+3/4 respectivly). (the brightness down (Fn+F6) has a keycode, but up (Fn+F7) does not, also wifi toggle (Fn+F8) does not return a keycode)
    • brightness control via menu works, untill you install AMD Fglrx (one from additional software/drivers gives Unspported Software in bottom right, but the one from AMD's site works fine) the brightness control bar is still there, but no change when you change it.



    if you need me to post terminal outputs or other information, just ask.

    thanks in advance!
    Last edited by C0NFU53D2; April 29th, 2013 at 09:19 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •