Results 1 to 9 of 9

Thread: gazp8 No mic input after system suspend (13.04)

  1. #1
    Join Date
    Oct 2008
    Beans
    7

    gazp8 No mic input after system suspend (13.04)

    After taking the laptop out of suspend, the internal mic input does not work.
    My current fix requires me to plug in an external mic into the input port, then remove it, after that the internal mic will work again.

    Using the 3.2.7 driver. Issue was not present when using 12.04.2 or 12.10.

  2. #2
    Join Date
    Jun 2010
    Beans
    1

    Re: gazp8 No mic input after system suspend (13.04)

    This is just a workaround but might help.

    Open a terminal (ctrl+alt+t) and type:
    sudo alsa force-reload

  3. #3
    Join Date
    Feb 2013
    Beans
    18

    Re: gazp8 No mic input after system suspend (13.04)

    Try checking your microphone with pavucontrol.

    Code:
    sudo apt-get install pavucontrol
    pavucontrol
    pavucontrol is the Pulse Audio control panel. Your microphone might just be disabled.

  4. #4
    Join Date
    Oct 2010
    Beans
    93

    Re: gazp8 No mic input after system suspend (13.04)

    Did you file a support ticket on this?

    This problem is repeated in the GazP9. Very bad form.

  5. #5
    Join Date
    May 2007
    Location
    Vermont
    Beans
    869
    Distro
    Ubuntu

    Re: gazp8 No mic input after system suspend (13.04)

    Quote Originally Posted by rorschachwalter View Post
    Did you file a support ticket on this?

    This problem is repeated in the GazP9. Very bad form.
    according to the OP it worked fine in 12.04.2 and 12.10, so it sounds like an upstream kernel driver regression.

    Have you guys tried the latest alsa drivers to see if its been fixed upstream yet? https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS
    Desktop: Windows 8 x64 | Intel Core i5-2500 | 16 GB DDR3 1333 | ATI 6950 2gb | 64gb Vertex 2/320gb/750gb/1tb hdd
    Laptop: System76 Lemur Ultra | Xubuntu 13.04 x64 | 2.5Ghz Intel Core i5-3210m | 8GB DDR31600 | Intel HD4000 | 500GB 7200rpm hybrid hdd

  6. #6
    Join Date
    Aug 2013
    Beans
    1

    Thumbs up Re: gazp8 No mic input after system suspend (13.04)

    Quote Originally Posted by KlipperKyle View Post
    Try checking your microphone with pavucontrol.

    Code:
    sudo apt-get install pavucontrol
    pavucontrol
    pavucontrol is the Pulse Audio control panel. Your microphone might just be disabled.

    I'm also on a gazp8 and this worked for me. Too bad we need a workaround tho.

    V

  7. #7
    Join Date
    Jan 2011
    Beans
    1

    Thumbs down Re: gazp8 No mic input after system suspend (13.04)

    I just got my gazp9 a few days ago and had this issue. Close the lid & the mic stops working. Here's my version of the work around:


    • Open lid.
    • Install pavucontrol as above.
    • Launch pavucontrol.
    • Click on the "Input Devices" tab.
    • Switch from "Internal Microphone" to "Microphone" from the "Port" dropdown.
    • Switch back.
    • Mic should now Work.


    Hope this helps.

    rjwiii

  8. #8
    Join Date
    Oct 2008
    Beans
    7

    Re: gazp8 No mic input after system suspend (13.04)

    Thanks for all of the help. It's working good for me.

  9. #9
    Join Date
    Nov 2010
    Beans
    19
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: gazp8 No mic input after system suspend (13.04)

    I also have a similarproblem on my gazp9 except that I don't need to suspend the computer for the mic not to work.
    I also use the workaround you mention, exactly the same steps but it's not consistent after reboot, I have to do it all over again...
    I was not expecting to babysit my ubuntu on a system76 computer. All threads I've read go to more or less the same solutions. And none have worked completely yet.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •