I tried to boot 13.04 from an USB stick in my Toshiba Satellite laptop (model S855-S5170), but I just get a black screen with a couple of purple flickering pixel lines at the top ...

I am currently using 12.10, but went through a PITA making it work; essentially because I had to stick with kernel version 3.5.0-17, since upgrading to any newer kernel version would produce the same result as with 13.04.

My laptop comes with an ATI Radeon GPU, and the Intel Graphics chipset can not be enabled on the BIOS (shame on me for not finding out more about this laptop before buying it) ... but it seems like the Radeon card is not well supported after 3.5.0-17; I had to lock this package version in Synaptic to avoid getting updates that would render the system unusable.

I am concerned that I will not be able to upgrade to any newer Ubuntu version in the future because of this problem ...

This is the line from lspci corresponding to the GPU:

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames XT/GL [Radeon HD 7600M Series]

Does anyone of the Ubuntu gurus out there know of something I could try (maybe in the kernel startup parameters) to make anything past 3.5.0-17 to work??

Any help will be deeply appreciated!!!