I think Cinnamon's new version which will come with Mint 15 is on Gnome 3.6 which is what Raring uses, so what incompatibility do you mean? The only problems is that distros like Arch have a broken cinnamon because they use bleeding-edge Gnome which is incompatible. But Linux Mint distro itself is likely to be fine. Right?