Results 1 to 9 of 9

Thread: Unmet dependencies while installing qt-sdk (libgl1-mesa-glx)

  1. #1
    Join Date
    Oct 2011
    Beans
    14

    Unmet dependencies while installing qt-sdk (libgl1-mesa-glx)

    Hey everyone!

    I am currently running Ubuntu 13.04 and I tried to install the qt sdk today.

    I used apt-get install qt-sdk and got an error that some packages have unmet dependencies. After digging a little deeper I found the responsible package:

    Code:
    libgl1-mesa-glx (= 9.1.1-0ubuntu3) but 9.2.0~git20130216.dd599188-0ubuntu0sarvatt~quantal is to be installed
    I searched for it with the synaptic package manager and pressed control+e to downgrade it but it says that when I downgrade the package then many other packages will be removed. Is it safe to downgrade? If not, what else can I do to fix it?
    Last edited by Gart3nzw3rg; April 29th, 2013 at 12:34 PM. Reason: Changed title to make it more relevant

  2. #2
    Join Date
    Feb 2008
    Beans
    4,856
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Need help with installing qt-sdk

    Nothing good has ever happened when I let the system remove packages.

    I have 32-bit Ubuntu 13.04 installed in VirtualBox. I just used Synaptic Package Manager to install qt-sdk. There was a warning message about phonon, but otherwise it went very smoothly. I'm pretty sure libgl1-mesa-glx was present before I installed qt-sdk.

    Did you upgrade to 13.04 or do a fresh install?

  3. #3
    Join Date
    Oct 2011
    Beans
    14

    Re: Need help with installing qt-sdk

    I upgraded to 13.04 but I had the same problem while I was still running 12.10. I can do a fresh install but I would prefer not to because then I would have to set up everthing again.

  4. #4
    Join Date
    Jun 2007
    Beans
    12,535

    Re: Unmet dependencies while installing qt-sdk (libgl1-mesa-glx)

    You have the xorg-edgers PPA installed (and you still have old quantal packages from it that are messing apt up). You should remove the PPA unless you still need it.
    Code:
    sudo apt-get install ppa-purge
    sudo ppa-purge ppa:xorg-edgers/ppa

  5. #5
    Join Date
    Oct 2011
    Beans
    14

    Re: Unmet dependencies while installing qt-sdk (libgl1-mesa-glx)

    Thanks for the response.

    When I try to remove it it says: "Warning: Could not find package list for PPA: xorg-edgers ppa"

    When I search for xorg in sources.list and sources.list.d/* I get:

    /etc/apt/sources.list.d/xorg-edgers-ppa-quantal.list.save:deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu quantal main

    Is that the PPA that needs to be removed?

  6. #6
    Join Date
    Jun 2007
    Beans
    12,535

    Re: Unmet dependencies while installing qt-sdk (libgl1-mesa-glx)

    Yeah, that's the one.

  7. #7
    Join Date
    Oct 2011
    Beans
    14

    Re: Unmet dependencies while installing qt-sdk (libgl1-mesa-glx)

    Sorry I just can't get to remove it. Whats the exact command that I need?

    No matter what I try, I get: Warning: Could not find package list for PPA: ...

  8. #8
    Join Date
    Jun 2007
    Beans
    12,535

    Re: Unmet dependencies while installing qt-sdk (libgl1-mesa-glx)

    That's probably because the deb line points to quantal when you're now on raring. You've got a mess on your hands. Personally, I would just go ahead and remove anything installed from that PPA and add back the Ubuntu repo version when done.

  9. #9
    Join Date
    Oct 2011
    Beans
    14

    Re: Unmet dependencies while installing qt-sdk (libgl1-mesa-glx)

    I think I solved it.

    I first added the xorg-edgers/ppa and then I run update/upgrade. After that I tried to install the qt-sdk again and it worked this time. Not sure if this is the proper way but it seems to be fine now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •