Major kernel version upgrades or ABI increases are installed automatically when a new linux-meta package is uploaded to the repos. i.e. the upgrade of that pulls in the new kernel version as a dependency on a dist-upgrade.

Until a new matching linux-meta version is uploaded, you will have to manually select and install the newer kernel versions.

There is no new linux-meta package matching the 3.9 kernel yet, so manual upgrade/install is it.