Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Having trouble setting up my firewall

  1. #11
    Join Date
    Apr 2013
    Beans
    124
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Having trouble setting up my firewall

    Quote Originally Posted by Dural View Post
    Alright I tried the same rules after I uninstalled and reinstalled UFW and GUFW. They still didn't work. I want to try using iptables, but the tutorial I used wasn't clear about where the finished script should be saved. So for the time being I've decided to keep the firewall off.
    If you are not hosting any server on your machine, as others said before, you should allow outgoing connections and block incoming ones which are not a response to a session started by one of your applications (which ufw does by default, unless the rules were altered).

    See this thread because I've had the same questions, too:

    http://ubuntuforums.org/showthread.php?t=2137243&

    The last message explains how to reset ufw and set it to default rules, though I would now add allow outgoing firstly, then deny incoming. You don't even need gufw, because the firewall once enabled is loaded at every startup.

    I also assume that you're behind a router. My router has a firewall, does some filtering, so if it's properly configured, it should do a good job for basic networking (browsing & email). Everytime I check the logs of the router I see how great it does in blocking & filtering. It is very important how you configure your browser (what it can or cannot do, there are some great add-ons which IMHO are really necessary) and what you visit and click after you're alone out there.

  2. #12
    Join Date
    Oct 2005
    Location
    Al Ain
    Beans
    8,802

    Re: Having trouble setting up my firewall

    Hmm, note that you don't really need a firewall script. Firewalls are mainly there to protect Windows machines.

  3. #13
    Join Date
    Jul 2005
    Beans
    83

    Re: Having trouble setting up my firewall

    Quote Originally Posted by clearski View Post
    If you are not hosting any server on your machine, as others said before, you should allow outgoing connections and block incoming ones which are not a response to a session started by one of your applications (which ufw does by default, unless the rules were altered).

    See this thread because I've had the same questions, too:

    http://ubuntuforums.org/showthread.php?t=2137243&

    The last message explains how to reset ufw and set it to default rules, though I would now add allow outgoing firstly, then deny incoming. You don't even need gufw, because the firewall once enabled is loaded at every startup.

    I also assume that you're behind a router. My router has a firewall, does some filtering, so if it's properly configured, it should do a good job for basic networking (browsing & email). Everytime I check the logs of the router I see how great it does in blocking & filtering. It is very important how you configure your browser (what it can or cannot do, there are some great add-ons which IMHO are really necessary) and what you visit and click after you're alone out there.
    I intend to do some testing of my web page on my computer. That would require instaling LAMP. Would that count as running a server?

  4. #14
    Join Date
    Jun 2011
    Location
    The Shadow Gallery
    Beans
    6,782

    Re: Having trouble setting up my firewall

    Quote Originally Posted by Dural View Post
    I intend to do some testing of my web page on my computer. That would require instaling LAMP. Would that count as running a server?
    any machine which provides a service is a server, and yes it would be a web server
    Feel Free to Bitcoin Tip: 135Rp4pwwYTHEJ4u8bxKaDQiC91N9LUoV2

    Backtrack - Giving machine guns to monkeys since 2006
    Kali-Linux - Adding a grenade launcher to the machine guns since 2013

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •