Page 5 of 5 FirstFirst ... 345
Results 41 to 45 of 45

Thread: Not Able to get wifi working under 13.04 (Ralink rt5390)

  1. #41
    Join Date
    Oct 2013

    Re: Not Able to get wifi working under 13.04 (Ralink rt5390)


    I have the same problem with Ralink RT5390 on a HP dv7 laptop.
    Everything was working fine with ubuntu 12.10, but after upgrading to 13.04
    and later to 13.10, the wifi was continuously connecting/disconnecting and was very slow.
    Hopefully, I had not removed my last 12.10 kernel version (3.5.0-28-generic),
    and found that if I boot with it the wifi is working fine.

    The kernel versions 3.8.x used with ubuntu 13.04 and 13.10 seem to have the problems.
    Also, when using kernel 3.5.0 to boot the wifi on/off button is working,
    while when booting with kernel 3.8.x this button is dead.

    From time to time (i.e. when new 3.8.x kernels are installed during ubuntu updates) I check if things are ok,
    but so far this is not the case and I am still going back using the older 3.5.0 kernel.

    It seems that something was broken for the ralink driver rt2800pci which is used
    going from kernel 3.5.x to 3.8.x and nobody has ever fixed it.

    To summarize:

    I have ubuntu 13.10 / Ralink RT5390 / HP dv7 and use the the rt2800pci driver (as it comes after installation)
    kernel version WiFi status WiFi button
    3.5.0-28-generic works well OK
    3.8.x slow with many disconnections not working

  2. #42
    Join Date
    Dec 2011

    Re: Not Able to get wifi working under 13.04 (Ralink rt5390)

    Running Ubuntu 12.04 (haven't tried 13.04) this fix worked for me! I re-did it once when it seemed to have stopped working, but I'm not sure that was necessary. There does seem to be some uncertainty on this thread about how much of the patching should be done as root. Sometimes, also, my network manager randomly jumps from one to three bars and back, but in any case, my wifi connection speed and reliability have improved enormously.

    This chipset has been on the market for a while, so I am curious why this problem has been ignored by Ubuntu.

    EDIT: This fix does sometimes give me faster connections, but it also causes a small but continuous 10KiB/s download (of undisclosed content) to occur for as long as I remain connected. Does anyone know if rt5390 works in 13.10? It appears that it doesn't, but I'm wondering whether to try it. Other distros that don't have this problem?
    Last edited by catsandogs; January 24th, 2014 at 04:29 PM.

  3. #43
    Join Date
    Jul 2011

    Re: Not Able to get wifi working under 13.04 (Ralink rt5390)

    Anybody got a copy of the driver they can share, has been down for a while (for me at least)
    Lubuntu 13.1 64bit

  4. #44
    Join Date
    Dec 2011

    Re: Not Able to get wifi working under 13.04 (Ralink rt5390)

    These forums only allow people to send documents they've already uploaded, and I don't know how to upload to this forum. The file is 5.2 mb or so, so it wouldn't be a big deal. Somebody actually did have it posted somewhere... So this lack of decent drivers is still a problem with 13.10?

    A distro that runs the rt5390 perfectly says that it uses a driver called rts_pstor when you give the command lspci -vvnn. That driver seems not to exist in Ubuntu 12.04, but I wonder if it could be installed.
    Last edited by catsandogs; January 25th, 2014 at 03:21 PM.

  5. #45
    Join Date
    Jun 2006

    Thumbs up [SOLVED] Re: Not Able to get wifi working under 13.04 (Ralink rt5390)

    I recently had to do this on a friend's HP laptop. To make it easy for other people to do the same, as well as automating the recompile after each kernel update, I made this complete instruction available on github. It includes the 2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO driver from mediatek, plus a patch to fix the compilation issue reported in this thread. It should work perfectly on Ubuntu 14.04.

Page 5 of 5 FirstFirst ... 345

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts