Results 1 to 7 of 7

Thread: External speakers do not work.

  1. #1
    Join Date
    Mar 2007
    Beans
    354
    Distro
    Ubuntu 12.04 Precise Pangolin

    External speakers do not work.

    I have Windows 7 and Ubuntu 10.10 on my Toshiba laptop. In windows everything is fine but in ubuntu if i plug in external speakers they do not work. Even when the external speakers are plugged in the laptop's internal speakers keep working. I searched for other forums but could not find a solution although many people seem to have this problem.

  2. #2
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: External speakers do not work.

    Could be an easy fix. Need some more info though.
    Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.
    [Terminal="Applications->Accessories->Terminal"]

  3. #3
    Join Date
    Mar 2007
    Beans
    354
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: External speakers do not work.

    Quote Originally Posted by lidex View Post
    Could be an easy fix. Need some more info though.
    Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.
    [Terminal="Applications->Accessories->Terminal"]
    http://www.alsa-project.org/db/?f=b6...3391326022cbdc

  4. #4
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: External speakers do not work.

    Try this. Using a Terminal="Applications->Accessories->Terminal"
    Open this file for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Insert this line at the bottom:
    Code:
     options snd-hda-intel model=thinkpad
    Save. Close. Reboot.
    Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
    On the output tab choose the correct device.

  5. #5
    Join Date
    Mar 2007
    Beans
    354
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: External speakers do not work.

    Quote Originally Posted by lidex View Post
    Try this. Using a Terminal="Applications->Accessories->Terminal"
    Open this file for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Insert this line at the bottom:
    Code:
     options snd-hda-intel model=thinkpad
    Save. Close. Reboot.
    Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
    On the output tab choose the correct device.
    Thanks! Worked like a charm.

  6. #6
    Join Date
    Apr 2007
    Location
    Oz
    Beans
    152
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: External speakers do not work.

    Seemed to work for me (fingers crossed).....so far speakers have been functioning non-stop for about 2 hours. Normally they fail after 10-50 minutes.

  7. #7
    Join Date
    Jan 2010
    Location
    Kolkata India
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: External speakers do not work.

    old thread, closed. Please feel free to start a new thread.
    “Progress is made by lazy men looking for easier ways to do things”
    — Robert A. Heinlein

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •