I solved my own problem! Rather than half of the linux community and not post actually how they did it, I'm going to do just that (mainly because I have a terrible memory and will probably re-install some point in the future)

My laptop is a Lenovo Y580 with nVidia Geforce 660M, 16GB of RAM (I upgraded myself from 6), an i7 3630QM and has the lower end display supporting resolutions of 1366x768.

I used a fresh install of Ubuntu 12.10.

This solved the problem of:
NVRM: failed to copy vbios to system memory
Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.
after reading several articles on the internet, I stumbled across several forums stating there was a bbswitch acpi hack for lenovo and figured since I had a lenovo, I'd try it out.

This is what I typed (from my bash history):
lspci | grep -i "VGA"
apt-add-repository ppa:ubuntu-x-swat/x-updates
apt-get purge nvidia-current nvidia-settings
add-apt-repository ppa:bumblebee/stable
apt-get update
apt-get install bumblebee bumblebee-nvidia git
git clone git://github.com/Bumblebee-Project/bbswitch.git -b hack-lenovo
cd bbswitch/
mkdir /usr/src/acpi-handle-hack-0.0.1
cp Makefile acpi-handle-hack.c /usr/src/acpi-handle-hack-0.0.1/
cp dkms/acpi-handle-hack.conf /usr/src/acpi-handle-hack-0.0.1/dkms.conf
dkms add acpi-handle-hack/0.0.1
dkms build acpi-handle-hack/0.0.1
dkms install acpi-handle-hack/0.0.1
echo acpi-handle-hack | sudo tee -a /etc/modules
update-initramfs -u
apt-get install virtualgl-libs:i386 libgl1-mesa-glx:i386 libc6:i386
After reboot, I ran:
optirun glxspheres
which returned:
OpenGL Renderer: GeForce GTX 660M/PCIe/SSE2
Good luck!