Results 1 to 4 of 4

Thread: samsung 900x3e - display artifacts

  1. #1
    Join Date
    Apr 2013

    samsung 900x3e - display artifacts


    I recently bought the samsung 900x3e ultrabook and installed ubuntu. Most things work fine, however, the screen shows artifacts (horizontal lines appearing over the screen - see screenshot).

    Is anyone else using the 900x3e with linux? Would be interesting to know if it is a hardware or software issue.

    Windows 8 runs fine if I turn the laptop on and start it directly. If I boot linux and then reboot to windows, some rest of the artifacts is also visible in windows.

  2. #2
    Join Date
    Jan 2012

    Re: samsung 900x3e - display artifacts

    Try switching off the acceleration (there will be no artefacts, but also no Compiz...): add
    nomodeset forcevesa
    to your kernel booting options (i.e. press TAB in Grub booting page).

    The same happens in Fedora and System Rescue CD.

  3. #3
    Join Date
    Jun 2006

    Re: samsung 900x3e - display artifacts

    I am having the same problem, running Arch Linux and using:
    xf86-video-intel 2.21.6-1

    Forcing vesa didn't help me

    Samsung 900x3e

    EDIT: Forcing Vesa does help!
    Last edited by murmlos; April 29th, 2013 at 04:24 PM.

  4. #4
    Join Date
    Jul 2011

    Re: samsung 900x3e - display artifacts

    I had this problem with ubuntu 13.04 too, but it disappeared with ubuntu 13.10.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts