Results 1 to 8 of 8

Thread: Totem from git problem.

  1. #1
    Join Date
    Aug 2006

    Totem from git problem.

    I tried building totem from gnome's git repository. It seemed to build fine. I also built from git grilo and grilo plugins.
    When I run Totem I get an error.

    GLib-GIO-ERROR **: Settings schema 'org.freedesktop.Tracker.FTS' does not contain a key named 'min-word-length'
    The environment has set GRL_PLUGIN_PATH=/usr/local/lib64/grilo-0.2


    I'm a bit confused about this error. There wasn't much I could find out about it. Just this commit message Is it a problem with totem, or tracker?

  2. #2

    Re: Totem from git problem.

    Don't see any issue here (on a gnome3 ppa + some extra install), if tracker isn't installed.
    If tracker is installed then it does cause the crash. Seems like a bug but the problem may be on the Ubuntu (ppa) side. You should file one I guess.

    If you wanted to keep totem git (3.9), & tracker then I'd go ahead & give it what it's looking for until fixed. (noting I am never too attached to any dev install..
    Now i've no idea what the default should be for min. word length, or if the setting should exist,. (here I've no great use for tracker so not an issue.

    So just an example - use gksudo gedit if you'd rather
    sudo nano /usr/share/glib-2.0/schemas/org.freedesktop.Tracker.FTS.gschema.xml
    insert/paste this at bottom as shown in screen ("<key type=.. & </key>" should line up, not sure this forum will cooperate
        <key type="i" name="min-word-length">
          <range min="0" max="200"/>
          <summary>Minimum length of a word to be indexed</summary>
          <description>Words with less characters than this length will be ignored by the indexer.</description>
    (then ctrl+o, enter, ctrl+x if using nano

    Then in terminal -
    sudo glib-compile-schemas /usr/share/glib-2.0/schemas
    Should run without error, if you get an error then correct, there may be an unrelated warning
    screen running no issue except a grilo grl-upnp warning that's no interest here either

    Ultimately better to get this fixed...

    (also to note - I've found that make installs of totem are better if installed to /usr with totem packages removed first.
    Last edited by mc4man; April 15th, 2013 at 05:35 AM. Reason: bolded something

  3. #3
    Join Date
    Aug 2006

    Re: Totem from git problem.

    Hi, thanks for all the help!

    Your solution to add that key to the schema worked. So totem starts.

    I made a bug report on gnome-buzilla ... It was decided invalid (rightly, I think).

  4. #4

    Re: Totem from git problem.

    Then not sure here where the issue is, guess the added schema key is ok. I'd keep an eye on the gnome ppa's, see what happens when they offer a 3.8 or higher totem

    If related to grilo it was decided to allow a while ago but as of yet never determined how to do so...
    leads to

  5. #5
    Join Date
    Aug 2006

    Re: Totem from git problem.

    I think the problem was an incompatibility caused by that gsettings key name removal between tracker 0.14 and 0.16.
    If I remove all the 0.14 tracker packages, leaving just the 0.16 packages, totem runs ok. (no need to edit the schema and glib-compile-schemas)

    I download the 0.14 tracker source from ubuntu, and references abound to that min-word-length gsettings key name.

    Probably the packages should conflict with one another, but you can have tracker 0.14 and 0.16 installed at the same time.

  6. #6

    Re: Totem from git problem.

    Makes sense - (I think
    When I was testing out here the only tracker prepackaged for this install was from the gnome3 ppa - tracker-0.15.4-0ubuntu1~raring1 which exhibits the issue with git totem.
    So hopefully the ppa will go to 0.16 when they offer a new totem (probably totem-3.8 release, I never tested that source with the 0.15 tracker to see if it's affected

    At the end of the day if one wants grilo support better atm to do one's own build.

    (curious - do you have any issue with the totem-mozilla plugin when building to /usr/local?

    (- also here I've decided for the moment to go with gst-1.1, for convenience the gnome3 experimental offers packages, the libav plugin uses a self contained libav source, probably 0.9, so doesn't need the current shared libav libs in 13.04

  7. #7
    Join Date
    Aug 2006

    Re: Totem from git problem.

    Since you asked ...

    I notice that there is a lack of plugins showing in mozilla when they are installed to the default /usr/local/lib/mozilla/plugins.

    If I export MOZ_PLUGIN_PATH=/usr/local/lib/mozilla/plugins and run firefox, then the plugins show up.
    If I create a directory ~/.mozilla/plugins/ and copy the plugins to that directory, then firefox also finds them.

    (I'm not much of multimedia-on-the-web person. So I never noticed the lack of plugins. It's odd that firefox doesn't search the path where by default the totem plugins are installed.)

    I guess you're asking about whether they work to watch video on the web? They did try to work, but mostly failed. I'm not sure whether these are real errors, or mistakes/oversights I made while building totem.

    This video failed at first when I clicked on it, then succeeded (it played).

    This video failed to play

  8. #8

    Re: totem-mozilla

    Was mainly asking whether it (browser plugin), worked without add. steps when installed to /usr/local. I've found it doesn't so the reason why I install to /usr where it's all good OOTB

    In any event the 1st. link was ok here, both in browser or in totem. The 2nd one is flash & again is ok as expected. (plugin in /usr


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts