Results 1 to 2 of 2

Thread: Transmission not using VPN connection

  1. #1
    Join Date
    Feb 2008
    Beans
    20

    Transmission not using VPN connection

    Hello

    I have a server at home running Ubuntu 12.04 for the purpose of downloading via transmission-daemon.
    My home server is connected to my VPN provider via openVPN.
    ifconfig shows RX bytes for eth0 is much greater than RX Bytes for tun0.
    Considering the vpn was connected right after boot, this seems to indicate to me that my downloads via transmission are not being transferred over the vpn connection.

    All inbound connections are blocked by my firewall, so the only peers I should be connected to, are those to whom I initiated the connection, and therefore should be routed via my vpn.

    If I ssh to my server and mtr google.com, I can see I am being routed via the vpn.

    So my question is, why is all my HTTP traffic (mtr) being directed via vpn, but my bit-torrent (transmission) traffic is not?

    Any help would be much appreciated.
    Last edited by mat28590; April 14th, 2013 at 10:22 PM.

  2. #2
    Join Date
    Feb 2008
    Beans
    20

    Re: Transmission not using VPN connection

    On the server I did:

    Code:
    sudo route add default dev tun0
    This seems to have solved this issue and all traffic is now being routed by via the vpn.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •