I've spent all night trying to get Ubuntu 12.10 x64 installed alongside Windows 8 on my new Samsung Series 7 laptop. After completely messing up the partitions the first time, I finally managed to do a clean install of Windows 8 after completely wiping all of the partitions, and that worked fine.

I then installed Ubuntu again, but this time the installer didn't see that Windows 8 was also on the system, so didn't give me the option to install alongside. (Windows 8 was installed EFI, and I ran the installer EFI, too) So, I manually installed Ubuntu to the second disk (in my case, sdc). I chose sda for the location for the bootloader (was this where I messed up?) sda is where Windows is installed.

Now when I try to boot into Windows, I get No Such Device and the UUID number (I think?). This is despite me trying everything I could with boot-repair. Here was my latest paste: http://paste.ubuntu.com/5707568/

I have nothing on this laptop yet, so I can completely refresh this if there is a better way. Fastboot and Secure boot are both disabled, by the way. Everything is in EFI, and the system will not boot unless it's in EFI mode.