Results 1 to 5 of 5

Thread: cannot build with python setup.py

  1. #1
    Join Date
    May 2009
    Location
    Austin, Texas USA
    Beans
    271
    Distro
    Ubuntu 14.04 Trusty Tahr

    cannot build with python setup.py

    Hi folks,

    I'm trying to build this lockbox application so I can evaluate it (storing important documents like tax returns and such):
    https://launchpad.net/lockbox


    Unfortunately I don't see any binary files for it so I have to build from source and I am completely clueless how to do so. There is a setup.py file in there which I ran, and it initially complained:

    Code:
    $ ./setup.py 
    To build lockbox you need https://launchpad.net/python-distutils-extra

    No problem, a quick "sudo apt-get install python-distutils-extra" fixed that problem. Now when I run the setup.py file I get this:

    Code:
    $ ./setup.py 
    ERROR: Python module gpgme not found
    ERROR: Python module MessageBox not found
    ERROR: Python module diskctl not found
    ERROR: Python module MessageBox not found
    ERROR: Python module gpgme not found
    ERROR: Python module diskctl not found
    ERROR: Python module MessageBox not found
    ERROR: Python module diskctl not found
    ERROR: Python module MessageBox not found

    I have tried searching those messages on google without any luck. I eventually found something called easy_install and set that up but whenever I try something like "sudo easy_install gpgme" it fails to find anything. Any idea how I get this gpgme, MessageBox, and diskctl stuff installed?
    Last edited by gamblor01; April 13th, 2013 at 03:22 PM.
    If all else fails, use fire.

  2. #2
    Join Date
    Nov 2007
    Beans
    7

    Re: cannot build with python setup.py

    apt-get install python-distutils-extra

    and then try python ./setup.py

  3. #3
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,480
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: cannot build with python setup.py

    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  4. #4
    Join Date
    May 2009
    Location
    Austin, Texas USA
    Beans
    271
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: cannot build with python setup.py

    Quote Originally Posted by gnuyoga View Post
    apt-get install python-distutils-extra

    and then try python ./setup.py
    Thanks but please see my original post. I already did this.


    Quote Originally Posted by 3rdalbum View Post
    This was actually how I initially attempted to install but it doesn't work because the packages are only built for precise and not quantal. Adding the PPA works fine but when I try to run sudo apt-get update I get this:

    Code:
    Err http://ppa.launchpad.net quantal/main Sources
      404  Not Found
    Err http://ppa.launchpad.net quantal/main amd64 Packages
      404  Not Found
    Err http://ppa.launchpad.net quantal/main i386 Packages
      404  Not Found
    Ign http://ppa.launchpad.net quantal/main Translation-en_US
    Ign http://ppa.launchpad.net quantal/main Translation-en
    Ign http://ppa.launchpad.net quantal/main Translation-en_US
    Ign http://ppa.launchpad.net quantal/main Translation-en
    Ign http://ppa.launchpad.net quantal/main Translation-en_US
    Ign http://ppa.launchpad.net quantal/main Translation-en
    Ign http://ppa.launchpad.net quantal/main Translation-en_US
    Ign http://ppa.launchpad.net quantal/main Translation-en
    Fetched 1,112 kB in 16s (67.6 kB/s)
    W: Failed to fetch http://ppa.launchpad.net/fabio-massaioli/lockbox-ppa/ubuntu/dists/quantal/main/source/Sources  404  Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/fabio-massaioli/lockbox-ppa/ubuntu/dists/quantal/main/binary-amd64/Packages  404  Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/fabio-massaioli/lockbox-ppa/ubuntu/dists/quantal/main/binary-i386/Packages  404  Not Found
    
    E: Some index files failed to download. They have been ignored, or old ones used instead.



    Thus, I decided to try and build this from source. So I still need to figure out how to get these python packages installed. Honestly it's not just for this project -- it's probably a useful thing to know in general how to get software to build with python...
    If all else fails, use fire.

  5. #5
    Join Date
    May 2009
    Location
    Austin, Texas USA
    Beans
    271
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: cannot build with python setup.py

    Ok so was able to get this installed. I wound up downloading the .deb file directly:

    https://launchpad.net/~fabio-massaio...-ppa/+packages


    I tried to install it with dpkg -i and it failed stating that it depends on python-gpgme which is not installed. So I ran "sudo apt-get install python-gpgme" and then lockbox automatically configured itself as well and is working.

    I guess I'll mark this as solved but with more and more things built with python, knowing how to satisfy build dependencies will come in handy. So far the following is all I know from this case:

    Code:
    sudo apt-get install python-distutils-extra python-gpgme
    If all else fails, use fire.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •