Results 1 to 3 of 3

Thread: Dell Inspiron 17R SE (7720) BIOS Screen?

  1. #1
    Join Date
    Apr 2013

    Dell Inspiron 17R SE (7720) BIOS Screen?

    Hello. Just got my new laptop. It has Ubuntu 11.10 already installed. Tried to open BIOS several times and I don't get it why it won't open. When I press F2 or other button that should pop up BIOS screen all I get is black screen with lots of white codes that goes down and I can't see what is written there because the new laptop loads so fast.. Any ideas?

  2. #2
    Join Date
    May 2012

    Re: Dell Inspiron 17R SE (7720) BIOS Screen?

    This may be a case of the blind leading the blind, but since I also have a 7720 (albeit with a broken win 8 instalation and Ubuntu on a hd i added myself) I'll suggest trying F12 on startup. but for me F2 works fine. Alternately you could try holding F2 before/through pushing the power button to make sure you dont miss it. otherwise hopefully someone jumps in who knows a bit more

  3. #3
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Dell Inspiron 17R SE (7720) BIOS Screen?

    UEFI/BIOS Boot keys - about halfway down on this Microsoft page

    Is this a new computer with the older version of Ubuntu. I would think they would at least use the LTS 12.04?

    Installing Ubuntu 12.10 x64 on Dell XPS 13 Alongside Windows from USB New user with Details post 10
    Dell Inspiron 17R SE - 12.04.2 but otherwise similar to XPS13 above
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts